summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-29 08:00:28 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-29 08:00:28 +0000
commitfc77021bfd3608ce0807635d0b3d04e87c417e34 (patch)
tree5298e622d5234b9989928a0a5831e53b699f773e /dev-ruby
parentx86 stable per bug 401157 (diff)
downloadgentoo-2-fc77021bfd3608ce0807635d0b3d04e87c417e34.tar.gz
gentoo-2-fc77021bfd3608ce0807635d0b3d04e87c417e34.tar.bz2
gentoo-2-fc77021bfd3608ce0807635d0b3d04e87c417e34.zip
Revision bump to create stable candidate without ruby19.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/shorturl/ChangeLog10
-rw-r--r--dev-ruby/shorturl/shorturl-0.8.8-r1.ebuild38
-rw-r--r--dev-ruby/shorturl/shorturl-0.8.8.ebuild6
3 files changed, 49 insertions, 5 deletions
diff --git a/dev-ruby/shorturl/ChangeLog b/dev-ruby/shorturl/ChangeLog
index a57c76ed8a93..c034d8b06e96 100644
--- a/dev-ruby/shorturl/ChangeLog
+++ b/dev-ruby/shorturl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/shorturl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shorturl/ChangeLog,v 1.15 2011/01/10 18:13:50 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shorturl/ChangeLog,v 1.16 2012/01/29 08:00:28 graaff Exp $
+
+*shorturl-0.8.8-r1 (29 Jan 2012)
+
+ 29 Jan 2012; Hans de Graaff <graaff@gentoo.org> shorturl-0.8.8.ebuild,
+ +shorturl-0.8.8-r1.ebuild:
+ Revision bump to create stable candidate without ruby19.
10 Jan 2011; Hans de Graaff <graaff@gentoo.org> shorturl-0.8.8.ebuild:
Keyword ~x86-macos.
diff --git a/dev-ruby/shorturl/shorturl-0.8.8-r1.ebuild b/dev-ruby/shorturl/shorturl-0.8.8-r1.ebuild
new file mode 100644
index 000000000000..40d8369dd68e
--- /dev/null
+++ b/dev-ruby/shorturl/shorturl-0.8.8-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shorturl/shorturl-0.8.8-r1.ebuild,v 1.1 2012/01/29 08:00:28 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README TODO"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A very simple library to use URL shortening services such as TinyURL or RubyURL."
+HOMEPAGE="http://shorturl.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-macos"
+IUSE=""
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.7+ruby-1.9.patch
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/ts_all.rb || die "tests failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ pushd doc &>/dev/null
+ dohtml -r . || die
+ popd &>/dev/null
+}
diff --git a/dev-ruby/shorturl/shorturl-0.8.8.ebuild b/dev-ruby/shorturl/shorturl-0.8.8.ebuild
index f7b92f71f595..11053c34cbe3 100644
--- a/dev-ruby/shorturl/shorturl-0.8.8.ebuild
+++ b/dev-ruby/shorturl/shorturl-0.8.8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shorturl/shorturl-0.8.8.ebuild,v 1.2 2011/01/10 18:13:50 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shorturl/shorturl-0.8.8.ebuild,v 1.3 2012/01/29 08:00:28 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 jruby"
+USE_RUBY="ruby18 jruby"
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_TASK_DOC=""