summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 04:25:25 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 04:25:25 +0000
commitf2e1e5082cdad7e38fcf8007830cb6d3d7cc3a54 (patch)
tree2993703df31f835ada8e1d5ab0b0da55ac88a790 /dev-ruby
parentPort to rspec helper for testing. (diff)
downloadgentoo-2-f2e1e5082cdad7e38fcf8007830cb6d3d7cc3a54.tar.gz
gentoo-2-f2e1e5082cdad7e38fcf8007830cb6d3d7cc3a54.tar.bz2
gentoo-2-f2e1e5082cdad7e38fcf8007830cb6d3d7cc3a54.zip
Port to rspec helper for testing.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/mixlib-shellout/ChangeLog7
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild6
2 files changed, 7 insertions, 6 deletions
diff --git a/dev-ruby/mixlib-shellout/ChangeLog b/dev-ruby/mixlib-shellout/ChangeLog
index 7d8a51efcc15..f8aac0b57976 100644
--- a/dev-ruby/mixlib-shellout/ChangeLog
+++ b/dev-ruby/mixlib-shellout/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/mixlib-shellout
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/ChangeLog,v 1.2 2012/08/11 08:45:09 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/ChangeLog,v 1.3 2012/08/14 04:25:25 flameeyes Exp $
+
+ 14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ mixlib-shellout-1.0.0.ebuild:
+ Port to rspec helper for testing.
11 Aug 2012; Benedikt Böhm <hollow@gentoo.org> mixlib-shellout-1.0.0.ebuild:
convert to EAPI4 and add test support
@@ -10,4 +14,3 @@
29 Apr 2012; Benedikt Böhm <hollow@gentoo.org>
+mixlib-shellout-1.0.0.ebuild, +metadata.xml:
initial version (required dependency of chef-0.10.10)
-
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild
index 104c9c8d95dc..7bf3220ff30c 100644
--- a/dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild,v 1.2 2012/08/11 08:45:09 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild,v 1.3 2012/08/14 04:25:25 flameeyes Exp $
EAPI=4
USE_RUBY="ruby18 ruby19"
RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_EXTRA_DOC="README.md"
@@ -21,5 +21,3 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"