summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-06 18:51:15 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-06 18:51:15 +0000
commitf20dde04ee59ebbfbd0054fa8220f5ead7716dc7 (patch)
treef73f7fa1f73a218287313b141ef7df2c87785717 /dev-ruby
parentppc stable wrt bug #509684 (diff)
downloadgentoo-2-f20dde04ee59ebbfbd0054fa8220f5ead7716dc7.tar.gz
gentoo-2-f20dde04ee59ebbfbd0054fa8220f5ead7716dc7.tar.bz2
gentoo-2-f20dde04ee59ebbfbd0054fa8220f5ead7716dc7.zip
Version bump for Rails 3.2.18, security bug 509706.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.2.18.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 6df3bc208f3a..6f1f0845c6e9 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.75 2014/05/04 11:30:08 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.76 2014/05/06 18:51:15 graaff Exp $
+
+*activemodel-3.2.18 (06 May 2014)
+
+ 06 May 2014; Hans de Graaff <graaff@gentoo.org> +activemodel-3.2.18.ebuild:
+ Version bump for Rails 3.2.18, security bug 509706.
04 May 2014; Manuel Rüger <mrueg@gentoo.org> activemodel-3.2.17.ebuild:
Add ruby20 support to slot 3.2.
diff --git a/dev-ruby/activemodel/activemodel-3.2.18.ebuild b/dev-ruby/activemodel/activemodel-3.2.18.ebuild
new file mode 100644
index 000000000000..664a6d658741
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.2.18.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.18.ebuild,v 1.1 2014/05/06 18:51:15 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/cases/helper.rb || die
+
+ # Fix bcrypt dependency since bcrypt uses semantic versioning.
+ sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
+}