summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-28 10:39:15 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-28 10:39:15 +0000
commitb5a5342c65d1afc39eaaa2f3f534765e7416b81c (patch)
tree1da6109173bf9008874ca5502cbfa2f4b8ac0738 /dev-ruby
parentFix Python module name. (diff)
downloadgentoo-2-b5a5342c65d1afc39eaaa2f3f534765e7416b81c.tar.gz
gentoo-2-b5a5342c65d1afc39eaaa2f3f534765e7416b81c.tar.bz2
gentoo-2-b5a5342c65d1afc39eaaa2f3f534765e7416b81c.zip
Version bump. Add ruby19. Stop trying to run the cucumber features since their setup is very brittle.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/spork/ChangeLog8
-rw-r--r--dev-ruby/spork/spork-0.9.0.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/spork/ChangeLog b/dev-ruby/spork/ChangeLog
index aca37cc7de72..e57ce9a4e608 100644
--- a/dev-ruby/spork/ChangeLog
+++ b/dev-ruby/spork/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/spork
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/spork/ChangeLog,v 1.6 2012/01/16 18:25:38 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/spork/ChangeLog,v 1.7 2012/01/28 10:39:15 graaff Exp $
+
+*spork-0.9.0 (28 Jan 2012)
+
+ 28 Jan 2012; Hans de Graaff <graaff@gentoo.org> +spork-0.9.0.ebuild:
+ Version bump. Add ruby19. Stop trying to run the cucumber features since
+ their setup is very brittle.
*spork-0.8.5 (16 Jan 2012)
diff --git a/dev-ruby/spork/spork-0.9.0.ebuild b/dev-ruby/spork/spork-0.9.0.ebuild
new file mode 100644
index 000000000000..c3fedba041a6
--- /dev/null
+++ b/dev-ruby/spork/spork-0.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/spork/spork-0.9.0.ebuild,v 1.1 2012/01/28 10:39:15 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+RUBY_FAKEGEM_EXTRAINSTALL="assets"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Spork is Tim Harper's implementation of test server."
+HOMEPAGE="http://github.com/timcharper/spork"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.6:2 )"
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die
+ # The features need a very fiddly and particular rails setup which
+ # we can't easily garantee.
+ #${RUBY} -Ilib -S cucumber features || die
+}