summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 01:06:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 01:06:58 +0000
commitaf55c91918a79b3f4b36cdf96e923b61fed45246 (patch)
treefa365a21b03a32e7b113a876e8f47627d210482a /dev-ruby
parentFix failed gpg signature on Manifest (diff)
downloadgentoo-2-af55c91918a79b3f4b36cdf96e923b61fed45246.tar.gz
gentoo-2-af55c91918a79b3f4b36cdf96e923b61fed45246.tar.bz2
gentoo-2-af55c91918a79b3f4b36cdf96e923b61fed45246.zip
Port to rspec helper for testing. Bump to EAPI 4.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/bluecloth/ChangeLog6
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.2.0.ebuild10
2 files changed, 7 insertions, 9 deletions
diff --git a/dev-ruby/bluecloth/ChangeLog b/dev-ruby/bluecloth/ChangeLog
index 06b6496f8720..187dbc4934eb 100644
--- a/dev-ruby/bluecloth/ChangeLog
+++ b/dev-ruby/bluecloth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/bluecloth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.57 2012/07/30 18:38:26 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.58 2012/08/14 01:06:58 flameeyes Exp $
+
+ 14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> bluecloth-2.2.0.ebuild:
+ Port to rspec helper for testing. Bump to EAPI 4.
30 Jul 2012; Hans de Graaff <graaff@gentoo.org> -bluecloth-2.1.0.ebuild:
Cleanup.
@@ -220,4 +223,3 @@
+bluecloth-1.0.0.ebuild:
Initial import. Ebuild submitted by Ben de Groot <ben@stijlstek.nl> in bug
#101561.
-
diff --git a/dev-ruby/bluecloth/bluecloth-2.2.0.ebuild b/dev-ruby/bluecloth/bluecloth-2.2.0.ebuild
index 28d43e50f654..8d3612073855 100644
--- a/dev-ruby/bluecloth/bluecloth-2.2.0.ebuild
+++ b/dev-ruby/bluecloth/bluecloth-2.2.0.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.2.0.ebuild,v 1.3 2012/05/01 18:24:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.2.0.ebuild,v 1.4 2012/08/14 01:06:58 flameeyes Exp $
-EAPI=2
+EAPI=4
USE_RUBY="ruby18 ruby19 ree18"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_TASK_DOC="docs"
RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
RUBY_FAKEGEM_DOCDIR="doc"
@@ -28,7 +29,6 @@ ruby_add_bdepend "
dev-ruby/hoe
dev-ruby/rake-compiler
test? (
- >=dev-ruby/rspec-2.4:2
dev-ruby/diff-lcs
dev-ruby/tidy-ext
)"
@@ -48,10 +48,6 @@ each_ruby_compile() {
${RUBY} -S rake compile || die "extension build failed"
}
-each_ruby_test() {
- ${RUBY} -S rspec spec || die "tests failed"
-}
-
all_ruby_install() {
doman man/man1/bluecloth.1