summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-17 19:50:39 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-17 19:50:39 +0000
commit5a4946c39bdb1b5860b9b7d82b9ec6c9bef87fc3 (patch)
treeb66c85d7118616ab312d84898faa31adfab69b79 /dev-ruby
parentAdd ruby21 target. (diff)
downloadgentoo-2-5a4946c39bdb1b5860b9b7d82b9ec6c9bef87fc3.tar.gz
gentoo-2-5a4946c39bdb1b5860b9b7d82b9ec6c9bef87fc3.tar.bz2
gentoo-2-5a4946c39bdb1b5860b9b7d82b9ec6c9bef87fc3.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/pdf-core/ChangeLog7
-rw-r--r--dev-ruby/pdf-core/pdf-core-0.5.0.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/pdf-core/ChangeLog b/dev-ruby/pdf-core/ChangeLog
index a2ceb7118ed9..77a1dbfb6399 100644
--- a/dev-ruby/pdf-core/ChangeLog
+++ b/dev-ruby/pdf-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/pdf-core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-core/ChangeLog,v 1.10 2014/09/17 13:51:30 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-core/ChangeLog,v 1.11 2014/10/17 19:50:39 mrueg Exp $
+
+*pdf-core-0.5.0 (17 Oct 2014)
+
+ 17 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +pdf-core-0.5.0.ebuild:
+ Version bump.
*pdf-core-0.4.0 (17 Sep 2014)
diff --git a/dev-ruby/pdf-core/pdf-core-0.5.0.ebuild b/dev-ruby/pdf-core/pdf-core-0.5.0.ebuild
new file mode 100644
index 000000000000..05a68f183111
--- /dev/null
+++ b/dev-ruby/pdf-core/pdf-core-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-core/pdf-core-0.5.0.ebuild,v 1.1 2014/10/17 19:50:39 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements low level PDF features for Prawn"
+HOMEPAGE="http://github.com/prawnpdf/pdf-core/"
+
+LICENSE="|| ( Ruby GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( =dev-ruby/pdf-inspector-1.1*
+ >=dev-ruby/pdf-reader-1.2 =dev-ruby/pdf-reader-1* )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" spec/spec_helper.rb || die
+}