summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-03-23 07:24:52 +0000
committerHans de Graaff <graaff@gentoo.org>2012-03-23 07:24:52 +0000
commit5664eeb371ed74c88620eeddbd79060c330c028d (patch)
tree6b0d7d64b8eb9f8bc004ccf57ca605267b465a46 /dev-ruby
parentVersion bump wrt bug #409391. (diff)
downloadgentoo-2-5664eeb371ed74c88620eeddbd79060c330c028d.tar.gz
gentoo-2-5664eeb371ed74c88620eeddbd79060c330c028d.tar.bz2
gentoo-2-5664eeb371ed74c88620eeddbd79060c330c028d.zip
Fix tests to use the proper interpreter and drop potential jeweler dependency. Add ruby19 and drop x86 as a consequence, bug 409399.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/fast_gettext/ChangeLog11
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-0.6.4-r1.ebuild49
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-ruby/fast_gettext/ChangeLog b/dev-ruby/fast_gettext/ChangeLog
index 7c317d298d6f..8995ac1a30df 100644
--- a/dev-ruby/fast_gettext/ChangeLog
+++ b/dev-ruby/fast_gettext/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/fast_gettext
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.8 2011/12/18 08:58:57 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.9 2012/03/23 07:24:52 graaff Exp $
+
+*fast_gettext-0.6.4-r1 (23 Mar 2012)
+
+ 23 Mar 2012; Hans de Graaff <graaff@gentoo.org>
+ +fast_gettext-0.6.4-r1.ebuild:
+ Fix tests to use the proper interpreter and drop potential jeweler
+ dependency. Add ruby19 and drop x86 as a consequence, bug 409399.
*fast_gettext-0.6.4 (18 Dec 2011)
diff --git a/dev-ruby/fast_gettext/fast_gettext-0.6.4-r1.ebuild b/dev-ruby/fast_gettext/fast_gettext-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..bd355a3f828c
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-0.6.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/fast_gettext-0.6.4-r1.ebuild,v 1.1 2012/03/23 07:24:52 graaff Exp $
+
+EAPI="4"
+
+# jruby support requires sqlite3 support for jruby.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/activerecord dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm Gemfile.lock || die
+
+ # Remove jeweler from Gemfile since it is not needed for tests.
+ sed -i '/jeweler/d' Gemfile || die
+
+ # Don't run a test that requires safe mode which we can't provide
+ # due to insecure directory settings for the portage dir. This spec
+ # also calls out to ruby which won't work with different ruby
+ # implementations.
+ sed -i -e '/can work in SAFE mode/,/end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the right ruby interpreter is used
+ sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die
+}