summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-16 13:02:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-16 13:02:46 +0000
commit4c4331cbb69c4d5f3adf34c47f27e89e2852cd05 (patch)
treeada03ceb2f48d50570597c96efd92931e8f31e0f /dev-ruby
parentStable on amd64 wrt bug #313263 (diff)
downloadgentoo-2-4c4331cbb69c4d5f3adf34c47f27e89e2852cd05.tar.gz
gentoo-2-4c4331cbb69c4d5f3adf34c47f27e89e2852cd05.tar.bz2
gentoo-2-4c4331cbb69c4d5f3adf34c47f27e89e2852cd05.zip
Add patch to reduce dependency over RDoc 2, closes bug #315585. Add ruby19 and jruby as compatible targets.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/plist/ChangeLog7
-rw-r--r--dev-ruby/plist/files/plist-3.1.0-nordoc.patch28
-rw-r--r--dev-ruby/plist/plist-3.1.0.ebuild10
3 files changed, 41 insertions, 4 deletions
diff --git a/dev-ruby/plist/ChangeLog b/dev-ruby/plist/ChangeLog
index c14f34532540..efdc77172f7b 100644
--- a/dev-ruby/plist/ChangeLog
+++ b/dev-ruby/plist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/plist
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/plist/ChangeLog,v 1.4 2010/02/24 07:15:58 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/plist/ChangeLog,v 1.5 2010/04/16 13:02:46 flameeyes Exp $
+
+ 16 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org> plist-3.1.0.ebuild,
+ +files/plist-3.1.0-nordoc.patch:
+ Add patch to reduce dependency over RDoc 2, closes bug #315585. Add ruby19
+ and jruby as compatible targets.
*plist-3.1.0 (24 Feb 2010)
diff --git a/dev-ruby/plist/files/plist-3.1.0-nordoc.patch b/dev-ruby/plist/files/plist-3.1.0-nordoc.patch
new file mode 100644
index 000000000000..30f289efae22
--- /dev/null
+++ b/dev-ruby/plist/files/plist-3.1.0-nordoc.patch
@@ -0,0 +1,28 @@
+Index: plist-3.1.0/Rakefile
+===================================================================
+--- plist-3.1.0.orig/Rakefile
++++ plist-3.1.0/Rakefile
+@@ -15,7 +15,13 @@ require 'rake/testtask'
+ require 'rake/packagetask'
+ require 'rake/gempackagetask'
+ require 'rake/contrib/rubyforgepublisher'
+-require 'rdoc/task'
++begin
++ require 'rdoc/task'
++ doctask = RDoc::Task
++rescue LoadError
++ require 'rake/rdoctask'
++ doctask = Rake::RDocTask
++end
+
+ $:.unshift(File.dirname(__FILE__) + "/lib")
+ require 'plist'
+@@ -104,7 +110,7 @@ task :update_rdoc => [ :rdoc ] do
+ end
+
+ # Genereate the RDoc documentation
+-RDoc::Task.new do |rdoc|
++doctask.new do |rdoc|
+ rdoc.title = "All-purpose Property List manipulation library"
+ rdoc.main = "README.rdoc"
+
diff --git a/dev-ruby/plist/plist-3.1.0.ebuild b/dev-ruby/plist/plist-3.1.0.ebuild
index 929879d2a317..76a78144e73d 100644
--- a/dev-ruby/plist/plist-3.1.0.ebuild
+++ b/dev-ruby/plist/plist-3.1.0.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/plist/plist-3.1.0.ebuild,v 1.1 2010/02/24 07:15:58 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/plist/plist-3.1.0.ebuild,v 1.2 2010/04/16 13:02:46 flameeyes Exp $
EAPI="2"
-USE_RUBY="ruby18"
+USE_RUBY="ruby18 ruby19 jruby"
RUBY_FAKEGEM_DOCDIR="rdoc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
-inherit ruby-fakegem
+inherit ruby-fakegem eutils
DESCRIPTION="A library to manipulate Property List files, also known as plists"
HOMEPAGE="http://plist.rubyforge.org/"
@@ -19,3 +19,7 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris
IUSE=""
ruby_add_bdepend test virtual/ruby-test-unit
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${P}-nordoc.patch"
+}