summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-12-18 12:58:19 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-12-18 12:58:19 +0000
commitacc275096874b40fca664522e757954d06a65ca0 (patch)
treed910959261a47c88ff10a309032dd179229da005 /dev-ruby/yajl-ruby
parentVersion bump. (diff)
downloadgentoo-2-acc275096874b40fca664522e757954d06a65ca0.tar.gz
gentoo-2-acc275096874b40fca664522e757954d06a65ca0.tar.bz2
gentoo-2-acc275096874b40fca664522e757954d06a65ca0.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/yajl-ruby')
-rw-r--r--dev-ruby/yajl-ruby/ChangeLog7
-rw-r--r--dev-ruby/yajl-ruby/yajl-ruby-1.2.0.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/yajl-ruby/ChangeLog b/dev-ruby/yajl-ruby/ChangeLog
index 6a311e988ef7..147e6ca7a8cd 100644
--- a/dev-ruby/yajl-ruby/ChangeLog
+++ b/dev-ruby/yajl-ruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/yajl-ruby
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yajl-ruby/ChangeLog,v 1.25 2013/10/06 11:42:30 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yajl-ruby/ChangeLog,v 1.26 2013/12/18 12:58:19 mrueg Exp $
+
+*yajl-ruby-1.2.0 (18 Dec 2013)
+
+ 18 Dec 2013; Manuel Rüger <mrueg@gentoo.org> +yajl-ruby-1.2.0.ebuild:
+ Version bump.
*yajl-ruby-1.1.0-r1 (06 Oct 2013)
diff --git a/dev-ruby/yajl-ruby/yajl-ruby-1.2.0.ebuild b/dev-ruby/yajl-ruby/yajl-ruby-1.2.0.ebuild
new file mode 100644
index 000000000000..ecc202030254
--- /dev/null
+++ b/dev-ruby/yajl-ruby/yajl-ruby-1.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yajl-ruby/yajl-ruby-1.2.0.ebuild,v 1.1 2013/12/18 12:58:19 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby C bindings to the Yajl JSON stream-based parser library"
+HOMEPAGE="http://github.com/brianmario/yajl-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/yajl"
+DEPEND="${DEPEND} dev-libs/yajl"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/yajl extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext/yajl CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
+ cp ext/yajl/yajl$(get_modname) lib/yajl/ || die
+}