summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-11 10:58:23 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-11 10:58:23 +0000
commit8b3c3e443e5fe6ae71e08b528671786459f7fb67 (patch)
treed8b541a095a136af8ff7d19496e8711dc75c9e14 /dev-ruby/webrobots
parentAdd ruby20 target. Cleanup old. (diff)
downloadgentoo-2-8b3c3e443e5fe6ae71e08b528671786459f7fb67.tar.gz
gentoo-2-8b3c3e443e5fe6ae71e08b528671786459f7fb67.tar.bz2
gentoo-2-8b3c3e443e5fe6ae71e08b528671786459f7fb67.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/webrobots')
-rw-r--r--dev-ruby/webrobots/ChangeLog7
-rw-r--r--dev-ruby/webrobots/webrobots-0.1.1-r1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ruby/webrobots/ChangeLog b/dev-ruby/webrobots/ChangeLog
index 64603e9f3eca..8c61978474f3 100644
--- a/dev-ruby/webrobots/ChangeLog
+++ b/dev-ruby/webrobots/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/webrobots
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/webrobots/ChangeLog,v 1.13 2013/09/15 09:30:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/webrobots/ChangeLog,v 1.14 2013/11/11 10:58:23 mrueg Exp $
+
+*webrobots-0.1.1-r1 (11 Nov 2013)
+
+ 11 Nov 2013; Manuel Rüger <mrueg@gentoo.org> +webrobots-0.1.1-r1.ebuild:
+ Add ruby20 target.
15 Sep 2013; Agostino Sarubbo <ago@gentoo.org> webrobots-0.1.1.ebuild:
Stable for x86, wrt bug #483694
diff --git a/dev-ruby/webrobots/webrobots-0.1.1-r1.ebuild b/dev-ruby/webrobots/webrobots-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..61b9eb9f6102
--- /dev/null
+++ b/dev-ruby/webrobots/webrobots-0.1.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/webrobots/webrobots-0.1.1-r1.ebuild,v 1.1 2013/11/11 10:58:23 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to help write robots.txt compliant web robots."
+HOMEPAGE="http://rubygems.org/gems/webrobots"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.4.4"
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/d' Rakefile test/helper.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+}