summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-02 06:14:48 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-02 06:14:48 +0000
commit8d9e96002b1d790d737c2abec5b79dd30144d03e (patch)
treec70554f784861cfebf222a7ee748ac2a0e957640 /dev-ruby/uconv
parentCleanup. (diff)
downloadgentoo-2-8d9e96002b1d790d737c2abec5b79dd30144d03e.tar.gz
gentoo-2-8d9e96002b1d790d737c2abec5b79dd30144d03e.tar.bz2
gentoo-2-8d9e96002b1d790d737c2abec5b79dd30144d03e.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/uconv')
-rw-r--r--dev-ruby/uconv/ChangeLog9
-rw-r--r--dev-ruby/uconv/uconv-0.6.1.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-ruby/uconv/ChangeLog b/dev-ruby/uconv/ChangeLog
index b93348e17c9f..274d882a38e3 100644
--- a/dev-ruby/uconv/ChangeLog
+++ b/dev-ruby/uconv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/uconv
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uconv/ChangeLog,v 1.21 2012/05/01 18:24:03 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uconv/ChangeLog,v 1.22 2013/07/02 06:14:48 graaff Exp $
+
+*uconv-0.6.1 (02 Jul 2013)
+
+ 02 Jul 2013; Hans de Graaff <graaff@gentoo.org> +uconv-0.6.1.ebuild:
+ Version bump.
01 May 2012; Raúl Porcel <armin76@gentoo.org> uconv-0.5.3.ebuild:
Drop ia64/sparc keywords
diff --git a/dev-ruby/uconv/uconv-0.6.1.ebuild b/dev-ruby/uconv/uconv-0.6.1.ebuild
new file mode 100644
index 000000000000..90fecec6c258
--- /dev/null
+++ b/dev-ruby/uconv/uconv-0.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uconv/uconv-0.6.1.ebuild,v 1.1 2013/07/02 06:14:48 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+inherit ruby-ng
+
+DESCRIPTION="A module to convert ISO/IEC 10646 (Unicode) string and Japanese strings"
+HOMEPAGE="http://www.yoshidam.net/Ruby.html#uconv"
+SRC_URI="http://www.yoshidam.net/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S=${PN}
+
+all_ruby_prepare() {
+ sed -i -e '/^\$CFLAGS = ""/d' extconf.rb || die "Unable to remove CFLAGS line"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 || die
+}
+
+each_ruby_install() {
+ emake V=1 DESTDIR="${D}" install || die
+}
+
+all_ruby_install() {
+ dodoc README*
+}