summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-03-19 20:12:01 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-03-19 20:12:01 +0000
commit69045d2a9aa8208041256d76ca053e3ff59738ae (patch)
treed92e17a8b64e47a204581ac48827365fcbd10c29 /dev-ruby/syslogger
parentVersion bump. Remove old. (diff)
downloadgentoo-2-69045d2a9aa8208041256d76ca053e3ff59738ae.tar.gz
gentoo-2-69045d2a9aa8208041256d76ca053e3ff59738ae.tar.bz2
gentoo-2-69045d2a9aa8208041256d76ca053e3ff59738ae.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/syslogger')
-rw-r--r--dev-ruby/syslogger/ChangeLog9
-rw-r--r--dev-ruby/syslogger/syslogger-1.6.1.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-ruby/syslogger/ChangeLog b/dev-ruby/syslogger/ChangeLog
index 3ffff64ed793..ab9ba56164ef 100644
--- a/dev-ruby/syslogger/ChangeLog
+++ b/dev-ruby/syslogger/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/syslogger
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syslogger/ChangeLog,v 1.13 2014/10/30 14:01:20 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syslogger/ChangeLog,v 1.14 2015/03/19 20:12:01 mrueg Exp $
+
+*syslogger-1.6.1 (19 Mar 2015)
+
+ 19 Mar 2015; Manuel Rüger <mrueg@gentoo.org> +syslogger-1.6.1.ebuild:
+ Version bump.
30 Oct 2014; Manuel Rüger <mrueg@gentoo.org> -syslogger-1.5.1-r1.ebuild,
syslogger-1.6.0.ebuild:
diff --git a/dev-ruby/syslogger/syslogger-1.6.1.ebuild b/dev-ruby/syslogger/syslogger-1.6.1.ebuild
new file mode 100644
index 000000000000..b1de71531b3b
--- /dev/null
+++ b/dev-ruby/syslogger/syslogger-1.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syslogger/syslogger-1.6.1.ebuild,v 1.1 2015/03/19 20:12:01 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+# if ever needed
+#GITHUB_USER="crohr"
+#GITHUB_PROJECT="${PN}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Drop-in replacement for the standard Logger, that logs to the syslog"
+HOMEPAGE="https://github.com/crohr/syslogger"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/rdoc-2.4.2 )"
+
+all_ruby_prepare() {
+ sed -i '/[Bb]undler/d' Rakefile || die
+}