summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-01-14 16:38:38 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-01-14 16:38:38 +0000
commitbe9c12fe0c9941112342c5893959b1ca5e7ac604 (patch)
tree530fcd5a45cbd5ac6f4eb5c3483bbcce6c2d3ea3 /dev-ruby/ruby-progressbar
parentCleanup (diff)
downloadgentoo-2-be9c12fe0c9941112342c5893959b1ca5e7ac604.tar.gz
gentoo-2-be9c12fe0c9941112342c5893959b1ca5e7ac604.tar.bz2
gentoo-2-be9c12fe0c9941112342c5893959b1ca5e7ac604.zip
Convert to ruby-ng.
(Portage version: 2.1.9.28/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/ChangeLog10
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-0.9-r1.ebuild30
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-ruby/ruby-progressbar/ChangeLog b/dev-ruby/ruby-progressbar/ChangeLog
index a7e2afbdc387..59302701b569 100644
--- a/dev-ruby/ruby-progressbar/ChangeLog
+++ b/dev-ruby/ruby-progressbar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-progressbar
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.32 2010/09/30 01:36:17 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.33 2011/01/14 16:38:38 matsuu Exp $
+
+*ruby-progressbar-0.9-r1 (14 Jan 2011)
+
+ 14 Jan 2011; MATSUU Takuto <matsuu@gentoo.org>
+ +ruby-progressbar-0.9-r1.ebuild:
+ Convert to ruby-ng.
30 Sep 2010; Brent Baude <ranger@gentoo.org>
ruby-progressbar-0.0.9.ebuild:
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-0.9-r1.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-0.9-r1.ebuild
new file mode 100644
index 000000000000..afb23f7a72b9
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-0.9-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ruby-progressbar-0.9-r1.ebuild,v 1.1 2011/01/14 16:38:38 matsuu Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+inherit ruby-ng
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="http://0xcc.net/ruby-progressbar/"
+SRC_URI="http://0xcc.net/ruby-progressbar/${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -I. test.rb || die "test failed"
+}
+
+each_ruby_install() {
+ doruby progressbar.rb
+}
+
+all_ruby_install() {
+ dodoc ChangeLog progressbar.*.rd || die
+}