summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-02-21 10:43:10 +0000
committerMamoru Komachi <usata@gentoo.org>2004-02-21 10:43:10 +0000
commitdb35509a0aa4aacf7d5ee93192a45f884eec9d1f (patch)
tree35e7ed1647ee168807eb1163a2739a8b36e63f73 /dev-ruby/ruby-opengl
parentFixed typo in updating ruby's symlinks (Manifest recommit) (diff)
downloadgentoo-2-db35509a0aa4aacf7d5ee93192a45f884eec9d1f.tar.gz
gentoo-2-db35509a0aa4aacf7d5ee93192a45f884eec9d1f.tar.bz2
gentoo-2-db35509a0aa4aacf7d5ee93192a45f884eec9d1f.zip
Initial import. Ebuild submitted by Mathias Gumz <gumz@cs.uni-magdeburg.de>, closing bug #23099
Diffstat (limited to 'dev-ruby/ruby-opengl')
-rw-r--r--dev-ruby/ruby-opengl/ChangeLog12
-rw-r--r--dev-ruby/ruby-opengl/files/digest-ruby-opengl-0.32c1
-rw-r--r--dev-ruby/ruby-opengl/files/ruby-opengl-0.32c-extconf-gentoo.diff20
-rw-r--r--dev-ruby/ruby-opengl/files/ruby-opengl-0.32c-font-gentoo.diff31
-rw-r--r--dev-ruby/ruby-opengl/metadata.xml5
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.32c.ebuild40
6 files changed, 109 insertions, 0 deletions
diff --git a/dev-ruby/ruby-opengl/ChangeLog b/dev-ruby/ruby-opengl/ChangeLog
new file mode 100644
index 000000000000..e1b94438b79e
--- /dev/null
+++ b/dev-ruby/ruby-opengl/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-ruby/ruby-opengl
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ChangeLog,v 1.1 2004/02/21 10:43:10 usata Exp $
+
+*ruby-opengl-0.32c (21 Feb 2004)
+
+ 21 Feb 2004; Mamoru KOMACHI <usata@gentoo.org> metadata.xml,
+ ruby-opengl-0.32c.ebuild, files/ruby-opengl-0.32c-extconf-gentoo.diff,
+ files/ruby-opengl-0.32c-font-gentoo.diff:
+ Initial import. Ebuild submitted by Mathias Gumz <gumz@cs.uni-magdeburg.de>,
+ closing bug #23099
+
diff --git a/dev-ruby/ruby-opengl/files/digest-ruby-opengl-0.32c b/dev-ruby/ruby-opengl/files/digest-ruby-opengl-0.32c
new file mode 100644
index 000000000000..0e85ce4db00e
--- /dev/null
+++ b/dev-ruby/ruby-opengl/files/digest-ruby-opengl-0.32c
@@ -0,0 +1 @@
+MD5 37e8a112dcc1b2e8446abfdab3b6ac07 rbogl-0.32c.tar.gz 81828
diff --git a/dev-ruby/ruby-opengl/files/ruby-opengl-0.32c-extconf-gentoo.diff b/dev-ruby/ruby-opengl/files/ruby-opengl-0.32c-extconf-gentoo.diff
new file mode 100644
index 000000000000..ab8bf168b1f5
--- /dev/null
+++ b/dev-ruby/ruby-opengl/files/ruby-opengl-0.32c-extconf-gentoo.diff
@@ -0,0 +1,20 @@
+--- extconf.rb.orig 2003-08-17 12:04:32.000000000 +0900
++++ extconf.rb 2004-01-31 18:22:35.000000000 +0900
+@@ -52,7 +52,7 @@
+
+ $objs = ["glu.o", "ogl.o", "rbogl.o"]
+ #have_library("pthread", "pthread_create")
+-if have_ogl_library(gl_libname) && have_ogl_library(glu_libname)
++if have_ogl_library(gl_libname, "glBegin") && have_ogl_library(glu_libname, "gluLookAt")
+ create_makefile("opengl")
+ File.rename("Makefile", "Makefile.ogl")
+ modules = modules + "opengl.#{CONFIG['DLEXT']}"
+@@ -63,7 +63,7 @@
+ end
+
+ $objs = ["glut.o"]
+-if have_library(glut_libname)
++if have_library(glut_libname, "glutInit")
+ create_makefile("glut")
+ File.rename("Makefile", "Makefile.glut")
+ modules = "glut.#{CONFIG['DLEXT']} " + modules
diff --git a/dev-ruby/ruby-opengl/files/ruby-opengl-0.32c-font-gentoo.diff b/dev-ruby/ruby-opengl/files/ruby-opengl-0.32c-font-gentoo.diff
new file mode 100644
index 000000000000..b84af221ad17
--- /dev/null
+++ b/dev-ruby/ruby-opengl/files/ruby-opengl-0.32c-font-gentoo.diff
@@ -0,0 +1,31 @@
+--- glut.c 2000-01-06 17:37:43.000000000 +0100
++++ glut.c 2003-06-29 19:45:40.000000000 +0200
+@@ -1457,6 +1457,28 @@
+ rb_define_const(mGLUT, "CURSOR_NONE", INT2NUM(GLUT_CURSOR_NONE));
+ rb_define_const(mGLUT, "CURSOR_FULL_CROSSHAIR", INT2NUM(GLUT_CURSOR_FULL_CROSSHAIR));
+
++#ifdef WIN32
++ rb_define_const(mGLUT, "BITMAP_8_BY_13", INT2NUM(2));
++ rb_define_const(mGLUT, "BITMAP_9_BY_15", INT2NUM(3));
++ rb_define_const(mGLUT, "BITMAP_TIMES_ROMAN_10", INT2NUM(4));
++ rb_define_const(mGLUT, "BITMAP_TIMES_ROMAN_24", INT2NUM(5));
++#if (GLUT_API_VERSION >= 3)
++ rb_define_const(mGLUT, "BITMAP_HELVETICA_10", INT2NUM(6));
++ rb_define_const(mGLUT, "BITMAP_HELVETICA_12", INT2NUM(7));
++ rb_define_const(mGLUT, "BITMAP_HELVETICA_18", INT2NUM(8));
++#endif
++#else /* non win32 */
++ rb_define_const(mGLUT, "BITMAP_8_BY_13", INT2NUM((unsigned int)&glutBitmap8By13));
++ rb_define_const(mGLUT, "BITMAP_9_BY_15", INT2NUM((unsigned int)&glutBitmap9By15));
++ rb_define_const(mGLUT, "BITMAP_TIMES_ROMAN_10", INT2NUM((unsigned int)&glutBitmapTimesRoman10));
++ rb_define_const(mGLUT, "BITMAP_TIMES_ROMAN_24", INT2NUM((unsigned int)&glutBitmapTimesRoman24));
++#if (GLUT_API_VERSION >= 3)
++ rb_define_const(mGLUT, "BITMAP_HELVETICA_10", INT2NUM((unsigned int)&glutBitmapHelvetica10));
++ rb_define_const(mGLUT, "BITMAP_HELVETICA_12", INT2NUM((unsigned int)&glutBitmapHelvetica12));
++ rb_define_const(mGLUT, "BITMAP_HELVETICA_18", INT2NUM((unsigned int)&glutBitmapHelvetica18));
++#endif
++#endif /* fonts */
++
+ callId = rb_intern("call");
+
+ WINDOW_CALLBACK_DEFINE(DisplayFunc);
diff --git a/dev-ruby/ruby-opengl/metadata.xml b/dev-ruby/ruby-opengl/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/ruby-opengl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.32c.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.32c.ebuild
new file mode 100644
index 000000000000..bc0252dce183
--- /dev/null
+++ b/dev-ruby/ruby-opengl/ruby-opengl-0.32c.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ruby-opengl-0.32c.ebuild,v 1.1 2004/02/21 10:43:10 usata Exp $
+
+inherit ruby
+
+DESCRIPTION="OpenGL / GLUT bindings for ruby"
+HOMEPAGE="http://www2.giganet.net/~yoshi/"
+SRC_URI="http://www2.giganet.net/~yoshi/rbogl-${PV}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+USE_RUBY="ruby16 ruby18"
+DEPEND=">=dev-lang/ruby-1.6"
+
+S=${WORKDIR}/opengl-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-extconf-gentoo.diff
+ epatch ${FILESDIR}/${P}-font-gentoo.diff
+}
+
+src_compile() {
+ ruby extconf.rb || die
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc README.EUC ChangeLog
+
+ insinto /usr/share/${PN}/sample
+ doins sample/*.rb
+}