summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-10 07:32:33 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-10 07:32:33 +0000
commitc18dca51a7477d34e36cedf2cea5daa6169f04f1 (patch)
treef3e3b0a868b6ca3f239fc22447c5af90459e5b4e /dev-ruby/ruby-odbc
parentVersion bump (diff)
downloadgentoo-2-c18dca51a7477d34e36cedf2cea5daa6169f04f1.tar.gz
gentoo-2-c18dca51a7477d34e36cedf2cea5daa6169f04f1.tar.bz2
gentoo-2-c18dca51a7477d34e36cedf2cea5daa6169f04f1.zip
Force --disable-dlopen per discussion in #179764.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-odbc')
-rw-r--r--dev-ruby/ruby-odbc/ChangeLog8
-rw-r--r--dev-ruby/ruby-odbc/ruby-odbc-0.99991-r1.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-ruby/ruby-odbc/ChangeLog b/dev-ruby/ruby-odbc/ChangeLog
index 3b436695b40a..e202eef69689 100644
--- a/dev-ruby/ruby-odbc/ChangeLog
+++ b/dev-ruby/ruby-odbc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-odbc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ChangeLog,v 1.17 2010/05/02 06:44:45 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ChangeLog,v 1.18 2010/07/10 07:32:33 graaff Exp $
+
+*ruby-odbc-0.99991-r1 (10 Jul 2010)
+
+ 10 Jul 2010; Hans de Graaff <graaff@gentoo.org>
+ +ruby-odbc-0.99991-r1.ebuild:
+ Force --disable-dlopen per discussion in #179764.
02 May 2010; Hans de Graaff <graaff@gentoo.org> -ruby-odbc-0.9997.ebuild:
Remove old version.
diff --git a/dev-ruby/ruby-odbc/ruby-odbc-0.99991-r1.ebuild b/dev-ruby/ruby-odbc/ruby-odbc-0.99991-r1.ebuild
new file mode 100644
index 000000000000..984a00a5a702
--- /dev/null
+++ b/dev-ruby/ruby-odbc/ruby-odbc-0.99991-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ruby-odbc-0.99991-r1.ebuild,v 1.1 2010/07/10 07:32:33 graaff Exp $
+
+EAPI=2
+
+# ruby19 → fails to build
+# jruby → uses C extensions
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RubyODBC - For accessing ODBC data sources from the Ruby language"
+HOMEPAGE="http://www.ch-werner.de/rubyodbc/"
+SRC_URI="http://www.ch-werner.de/rubyodbc/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-db/unixODBC-2.0.6"
+RDEPEND="${DEPEND}"
+
+# tests require to have an ODBC service enabled, so we can't run them
+# for now :(
+RESTRICT=test
+
+all_ruby_prepare() {
+ # Make sure that it doesn't try to use the absolute-local path for
+ # the extension as we'd be unable to run it properly otherwise.
+ sed -i -e 's:\./odbc:odbc:' test/{,utf8/}test.rb || die
+
+ # Since lib should not get installed avoid it entirely…
+ mv lib contrib || die
+}
+
+each_ruby_configure() {
+ for dir in ext ext/utf8; do
+ ${RUBY} -C${dir} extconf.rb --disable-dlopen || die "extconf (${dir}) failed"
+ done
+}
+
+each_ruby_compile() {
+ for dir in ext ext/utf8; do
+ emake -C${dir} || die "emake (${dir}) failed"
+ done
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ ruby_fakegem_newins ext/odbc.so lib/odbc.so
+ ruby_fakegem_newins ext/utf8/odbc_utf8.so lib/odbc_utf8.so
+}
+
+all_ruby_install() {
+ all_fakegem_install
+ dohtml doc/*.html || die
+}