summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-08-11 07:50:47 +0000
committerHans de Graaff <graaff@gentoo.org>2013-08-11 07:50:47 +0000
commitcb79f0b95dbf2a1e5bef9414d86324c9eba656f2 (patch)
tree9fe027c7b3d7e02d898ba8f5eb38cddeeea3cf09 /dev-ruby/rspec
parentCleanup. (diff)
downloadgentoo-2-cb79f0b95dbf2a1e5bef9414d86324c9eba656f2.tar.gz
gentoo-2-cb79f0b95dbf2a1e5bef9414d86324c9eba656f2.tar.bz2
gentoo-2-cb79f0b95dbf2a1e5bef9414d86324c9eba656f2.zip
Cleanup.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rspec')
-rw-r--r--dev-ruby/rspec/ChangeLog5
-rw-r--r--dev-ruby/rspec/rspec-1.3.1-r1.ebuild74
2 files changed, 4 insertions, 75 deletions
diff --git a/dev-ruby/rspec/ChangeLog b/dev-ruby/rspec/ChangeLog
index ed02ac9c52b5..27a50eab37bd 100644
--- a/dev-ruby/rspec/ChangeLog
+++ b/dev-ruby/rspec/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/rspec
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.152 2013/08/03 07:40:04 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.153 2013/08/11 07:50:47 graaff Exp $
+
+ 11 Aug 2013; Hans de Graaff <graaff@gentoo.org> -rspec-1.3.1-r1.ebuild:
+ Cleanup.
03 Aug 2013; Agostino Sarubbo <ago@gentoo.org> rspec-1.3.2.ebuild:
Stable for sparc, wrt bug #472910
diff --git a/dev-ruby/rspec/rspec-1.3.1-r1.ebuild b/dev-ruby/rspec/rspec-1.3.1-r1.ebuild
deleted file mode 100644
index d734e6190744..000000000000
--- a/dev-ruby/rspec/rspec-1.3.1-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.1-r1.ebuild,v 1.10 2013/01/15 06:12:11 zerochaos Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc TODO.txt Ruby1.9.rdoc Upgrade.rdoc"
-
-RUBY_FAKEGEM_BINWRAP="spec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE=""
-
-# it's actually optional, but tests fail if it's not installed and
-# some other package might fail tests, so require it anyway.
-ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.2"
-
-ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.0.0 )"
-
-RDEPEND="!<dev-ruby/rspec-rails-${PV}"
-
-# don't require test dependencies for jruby since we cannot run them
-# for now (fakefs doesn't work).
-#
-# We should add nokogiri here to make sure that we test as much as
-# possible, but since it's yet unported to 1.9 and the nokogiri-due
-# tests fail for sure, we'll be waiting on it.
-USE_RUBY="ruby18 ree18" \
- ruby_add_bdepend "test? (
- >=dev-ruby/hoe-2.0.0
- dev-ruby/zentest
- >=dev-ruby/syntax-1.0
- >=dev-ruby/fakefs-0.2.1 )"
-
-# the testsuite skips over heckle for Ruby 1.9 so we only request it for 1.8
-USE_RUBY="ruby18 ree18" \
- ruby_add_bdepend "test? ( >=dev-ruby/heckle-1.4.3 )"
-
-all_ruby_prepare() {
- # Replace reference to /tmp to our temporary directory to avoid
- # sandbox-related failure.
- sed -i \
- -e "s:/tmp:${T}:" \
- spec/spec/runner/command_line_spec.rb || die
-}
-
-src_test() {
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
- ruby-ng_src_test
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ewarn "Tests for JRuby are disabled because dev-ruby/fakefs does not currently support"
- ewarn "JRuby properly and it's needed to run the tests."
- ;;
- *)
- each_fakegem_test
- ;;
- esac
-}