summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-10-10 19:49:09 +0000
committerHans de Graaff <graaff@gentoo.org>2011-10-10 19:49:09 +0000
commitcf0542e5e69c071cb0251d71e160b352a8c1efea (patch)
treef4da47f2396e01b2d3a4cdf68a9427f03cf3c33c /dev-ruby/rcov
parentFix ChangeLog entry. (diff)
downloadgentoo-2-cf0542e5e69c071cb0251d71e160b352a8c1efea.tar.gz
gentoo-2-cf0542e5e69c071cb0251d71e160b352a8c1efea.tar.bz2
gentoo-2-cf0542e5e69c071cb0251d71e160b352a8c1efea.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rcov')
-rw-r--r--dev-ruby/rcov/ChangeLog9
-rw-r--r--dev-ruby/rcov/rcov-0.9.11.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-ruby/rcov/ChangeLog b/dev-ruby/rcov/ChangeLog
index 66d4c985d8f8..7ceb95d2e78e 100644
--- a/dev-ruby/rcov/ChangeLog
+++ b/dev-ruby/rcov/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rcov
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.18 2010/09/19 09:27:23 graaff Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.19 2011/10/10 19:49:09 graaff Exp $
+
+*rcov-0.9.11 (10 Oct 2011)
+
+ 10 Oct 2011; Hans de Graaff <graaff@gentoo.org> +rcov-0.9.11.ebuild:
+ Version bump.
*rcov-0.9.9 (19 Sep 2010)
diff --git a/dev-ruby/rcov/rcov-0.9.11.ebuild b/dev-ruby/rcov/rcov-0.9.11.ebuild
new file mode 100644
index 000000000000..bf59f9e430ac
--- /dev/null
+++ b/dev-ruby/rcov/rcov-0.9.11.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/rcov-0.9.11.ebuild,v 1.1 2011/10/10 19:49:09 graaff Exp $
+
+EAPI=4
+
+# The documenttion indicates that rcov does not work with (reliably)
+# with ruby 1.9. Use ruby 1.9's built in coverage or simplecov instead.
+USE_RUBY="ruby18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="test_rcovrt"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="THANKS BLURB"
+
+inherit ruby-fakegem versionator eutils
+
+DESCRIPTION="A ruby code coverage analysis tool"
+HOMEPAGE="http://eigenclass.org/hiki.rb?rcov"
+#SRC_URI="http://github.com/relevance/${PN}/tarball/release_$(replace_all_version_separators _) -> ${P}.tgz"
+SRC_URI="http://github.com/relevance/${PN}/tarball/b5513cae5ea3348d97c21a3c324d8e8a7768e814 -> ${P}.tgz"
+
+RUBY_S="relevance-${PN}-*"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# TODO: both emacs and vim support are present in this package, they
+# should probably be added to the ebuild as well.
+IUSE=""
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.7.1-jruby.patch
+
+ # Without this change, testing will always cause the extension to
+ # be rebuilt, and we don't want that.
+ sed -i -e '/:test_rcovrt =>/s| => \[.*\]||' Rakefile || die "Rakefile fix failed"
+
+ # remove pre-packaged jar file (d'oh!)
+ rm lib/rcovrt.jar || die
+
+ # Remove test suite with failing tests that upstream believes to
+ # work correctly so that we can run the remainder of tests.
+ # https://github.com/relevance/rcov/issues/40
+ rm test/code_coverage_analyzer_test.rb || die
+
+}
+
+each_ruby_compile() {
+ if [[ $(basename ${RUBY}) = "jruby" ]]; then
+ ${RUBY} -S rake lib/rcovrt.jar || die "build failed"
+ else
+ ${RUBY} -S rake ext/rcovrt/rcovrt.so || die "build failed"
+ cp ext/rcovrt/rcovrt.so lib/ || die
+ fi
+}