summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-04-05 22:00:22 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-04-05 22:00:22 +0000
commitd54522cf1869273f206489b9e3d345591bfd23cf (patch)
treed31da91becee6c09056af7fe99853dc5521c84c4 /dev-ruby/racc
parentMove file to arch/arm (diff)
downloadgentoo-2-d54522cf1869273f206489b9e3d345591bfd23cf.tar.gz
gentoo-2-d54522cf1869273f206489b9e3d345591bfd23cf.tar.bz2
gentoo-2-d54522cf1869273f206489b9e3d345591bfd23cf.zip
Remove ree18 and ruby18 target. Cleanup old.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/racc')
-rw-r--r--dev-ruby/racc/ChangeLog7
-rw-r--r--dev-ruby/racc/files/racc-1.4.6-test-unit.patch13
-rw-r--r--dev-ruby/racc/racc-1.4.10.ebuild85
-rw-r--r--dev-ruby/racc/racc-1.4.11.ebuild4
-rw-r--r--dev-ruby/racc/racc-1.4.8.ebuild85
-rw-r--r--dev-ruby/racc/racc-1.4.9.ebuild4
6 files changed, 10 insertions, 188 deletions
diff --git a/dev-ruby/racc/ChangeLog b/dev-ruby/racc/ChangeLog
index 92cbcbe1eeda..9de0245400fb 100644
--- a/dev-ruby/racc/ChangeLog
+++ b/dev-ruby/racc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/racc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.108 2014/01/26 13:06:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.109 2014/04/05 22:00:22 mrueg Exp $
+
+ 05 Apr 2014; Manuel Rüger <mrueg@gentoo.org>
+ -files/racc-1.4.6-test-unit.patch, -racc-1.4.10.ebuild, -racc-1.4.8.ebuild,
+ racc-1.4.11.ebuild, racc-1.4.9.ebuild:
+ Remove ree18 and ruby18 target. Cleanup old.
26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> racc-1.4.9.ebuild:
Stable for alpha, wrt bug #483254
diff --git a/dev-ruby/racc/files/racc-1.4.6-test-unit.patch b/dev-ruby/racc/files/racc-1.4.6-test-unit.patch
deleted file mode 100644
index 657454ac1113..000000000000
--- a/dev-ruby/racc/files/racc-1.4.6-test-unit.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: racc-1.4.6/test/helper.rb
-===================================================================
---- racc-1.4.6.orig/test/helper.rb
-+++ racc-1.4.6/test/helper.rb
-@@ -84,5 +84,8 @@ module Racc
- result ? assert(result) : raise(cmd)
- end
- end
-+
-+ def default_test
-+ end
- end
- end
diff --git a/dev-ruby/racc/racc-1.4.10.ebuild b/dev-ruby/racc/racc-1.4.10.ebuild
deleted file mode 100644
index cf054b1b0254..000000000000
--- a/dev-ruby/racc/racc-1.4.10.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.10.ebuild,v 1.2 2013/12/26 09:27:43 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby18 ruby19 ruby20 ruby21 jruby"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A LALR(1) parser generator for Ruby"
-HOMEPAGE="https://github.com/tenderlove/racc"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-all_ruby_prepare() {
- sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
-
- # Avoid depending on rake-compiler since we don't use it to compile
- # the extension.
- sed -i -e '/rake-compiler/ s:^:#:' -e '/extensiontask/ s:^:#:' Rakefile
- sed -i -e '/ExtensionTask/,/^ end/ s:^:#:' Rakefile
-
- # Avoid isolation since dependencies are not properly declared.
- sed -i -e 's/, :isolate//' Rakefile || die
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Some tests are broken on jruby, avoid them. We used to
- # avoid all tests so this is not a regression for us.
- rm test/test_racc_command.rb || die
- ;;
- *ruby18)
- sed -i -e '/test_norule_y/,/end/ s:^:#:' \
- -e '/test_unterm_y/,/end/ s:^:#:' test/test_racc_command.rb || die
- ;;
- *)
- ${RUBY} -Cext/racc extconf.rb || die
- ;;
- esac
-}
-
-each_ruby_compile() {
- case ${RUBY} in
- *jruby)
- einfo "Under JRuby, racc cannot use the shared object parser, so instead"
- einfo "you have to rely on the pure Ruby implementation."
- ;;
- *ruby18)
- einfo "No longer compiles with ruby 1.8, only the pure Ruby implementation is used."
- ;;
- *)
- emake V=1 -Cext/racc
- # Copy over the file here so that we don't have to do
- # special ruby install for JRuby and the other
- # implementations.
- cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
- ;;
- esac
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib -S testrb test/test_*.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- dodoc -r rdoc
-
- docinto examples
- dodoc -r sample
-}
diff --git a/dev-ruby/racc/racc-1.4.11.ebuild b/dev-ruby/racc/racc-1.4.11.ebuild
index 39c843bf0b8e..7be5eb1f188d 100644
--- a/dev-ruby/racc/racc-1.4.11.ebuild
+++ b/dev-ruby/racc/racc-1.4.11.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.11.ebuild,v 1.1 2014/01/13 07:19:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.11.ebuild,v 1.2 2014/04/05 22:00:22 mrueg Exp $
EAPI=5
-USE_RUBY="ruby18 ruby19 ruby20 ruby21 jruby"
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_TASK_DOC="docs"
diff --git a/dev-ruby/racc/racc-1.4.8.ebuild b/dev-ruby/racc/racc-1.4.8.ebuild
deleted file mode 100644
index 1b428885cc44..000000000000
--- a/dev-ruby/racc/racc-1.4.8.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.8.ebuild,v 1.13 2014/01/05 10:51:35 graaff Exp $
-
-EAPI=4
-
-USE_RUBY="ree18 ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A LALR(1) parser generator for Ruby"
-HOMEPAGE="http://www.loveruby.net/en/racc.html"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_bdepend "dev-ruby/rake
- doc? ( dev-ruby/hoe )
- test? ( dev-ruby/hoe )"
-
-all_ruby_prepare() {
- sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
-
- # Avoid depending on rake-compiler since we don't use it to compile
- # the extension.
- sed -i -e '/rake-compiler/ s:^:#:' -e '/extensiontask/ s:^:#:' Rakefile
- sed -i -e '/ExtensionTask/,/^ end/ s:^:#:' Rakefile
-
- # Avoid isolation since dependencies are not properly declared.
- sed -i -e 's/, :isolate//' Rakefile || die
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- ${RUBY} -Cext/racc extconf.rb || die
- ;;
- esac
-}
-
-each_ruby_compile() {
- case ${RUBY} in
- *jruby)
- einfo "Under JRuby, racc cannot use the shared object parser, so instead"
- einfo "you have to rely on the pure Ruby implementation."
- ;;
- *)
- emake -Cext/racc
- # Copy over the file here so that we don't have to do
- # special ruby install for JRuby and the other
- # implementations.
- cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
- ;;
- esac
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ewarn "Using JRuby 1.5.2 the tests are currently badly broken,"
- ewarn "so they are disabled until a new racc or a new JRuby is"
- ewarn "released."
- ;;
- *)
- each_fakegem_test
- ;;
- esac
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- dodoc -r rdoc
-
- docinto examples
- dodoc -r sample
-}
diff --git a/dev-ruby/racc/racc-1.4.9.ebuild b/dev-ruby/racc/racc-1.4.9.ebuild
index 79e050ca31b5..b3c2f462c68d 100644
--- a/dev-ruby/racc/racc-1.4.9.ebuild
+++ b/dev-ruby/racc/racc-1.4.9.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.9.ebuild,v 1.12 2014/01/26 13:06:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.9.ebuild,v 1.13 2014/04/05 22:00:22 mrueg Exp $
EAPI=4
-USE_RUBY="ruby18 ruby19 ruby20 jruby"
+USE_RUBY="ruby19 ruby20 jruby"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_TASK_DOC="docs"