summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-07-16 05:25:46 +0000
committerHans de Graaff <graaff@gentoo.org>2015-07-16 05:25:46 +0000
commit2292f9e943a1c22adaa1c413f45f14f3fc30a650 (patch)
treebb6a31f222193cc155c9de29f969c5f7944e4df2 /dev-ruby/pdf-core
parentVersion bump. (diff)
downloadgentoo-2-2292f9e943a1c22adaa1c413f45f14f3fc30a650.tar.gz
gentoo-2-2292f9e943a1c22adaa1c413f45f14f3fc30a650.tar.bz2
gentoo-2-2292f9e943a1c22adaa1c413f45f14f3fc30a650.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/pdf-core')
-rw-r--r--dev-ruby/pdf-core/ChangeLog7
-rw-r--r--dev-ruby/pdf-core/pdf-core-0.6.0.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/pdf-core/ChangeLog b/dev-ruby/pdf-core/ChangeLog
index 887cd2032f55..6c40ff28c29e 100644
--- a/dev-ruby/pdf-core/ChangeLog
+++ b/dev-ruby/pdf-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/pdf-core
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-core/ChangeLog,v 1.15 2015/07/06 06:54:01 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-core/ChangeLog,v 1.16 2015/07/16 05:25:46 graaff Exp $
+
+*pdf-core-0.6.0 (16 Jul 2015)
+
+ 16 Jul 2015; Hans de Graaff <graaff@gentoo.org> +pdf-core-0.6.0.ebuild:
+ Version bump.
06 Jul 2015; Hans de Graaff <graaff@gentoo.org> pdf-core-0.5.1.ebuild:
Add ruby22.
diff --git a/dev-ruby/pdf-core/pdf-core-0.6.0.ebuild b/dev-ruby/pdf-core/pdf-core-0.6.0.ebuild
new file mode 100644
index 000000000000..4e1c4c842cea
--- /dev/null
+++ b/dev-ruby/pdf-core/pdf-core-0.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-core/pdf-core-0.6.0.ebuild,v 1.1 2015/07/16 05:25:46 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements low level PDF features for Prawn"
+HOMEPAGE="https://github.com/prawnpdf/pdf-core/"
+
+LICENSE="|| ( Ruby GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( =dev-ruby/pdf-inspector-1.1*
+ >=dev-ruby/pdf-reader-1.2 =dev-ruby/pdf-reader-1* )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" spec/spec_helper.rb || die
+}