summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-09-01 06:19:33 +0000
committerHans de Graaff <graaff@gentoo.org>2012-09-01 06:19:33 +0000
commit7691f375d44bf52bb42f421abd2cfe429c39d5e4 (patch)
tree6da0887295374d8dd90745859cb232fdbd3d3717 /dev-ruby/narray
parentEAPI=4, add ree18,ruby19,jruby, use rspec recipe for testing. (diff)
downloadgentoo-2-7691f375d44bf52bb42f421abd2cfe429c39d5e4.tar.gz
gentoo-2-7691f375d44bf52bb42f421abd2cfe429c39d5e4.tar.bz2
gentoo-2-7691f375d44bf52bb42f421abd2cfe429c39d5e4.zip
Cleanup.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/narray')
-rw-r--r--dev-ruby/narray/ChangeLog6
-rw-r--r--dev-ruby/narray/narray-0.5.9_p6.ebuild28
-rw-r--r--dev-ruby/narray/narray-0.6.0.1-r1.ebuild54
3 files changed, 5 insertions, 83 deletions
diff --git a/dev-ruby/narray/ChangeLog b/dev-ruby/narray/ChangeLog
index 33a9b3320ba7..2650c56ea5ec 100644
--- a/dev-ruby/narray/ChangeLog
+++ b/dev-ruby/narray/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/narray
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.51 2012/06/09 07:50:49 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.52 2012/09/01 06:19:33 graaff Exp $
+
+ 01 Sep 2012; Hans de Graaff <graaff@gentoo.org> -narray-0.5.9_p6.ebuild,
+ -narray-0.6.0.1-r1.ebuild:
+ Cleanup.
*narray-0.6.0.1-r2 (09 Jun 2012)
diff --git a/dev-ruby/narray/narray-0.5.9_p6.ebuild b/dev-ruby/narray/narray-0.5.9_p6.ebuild
deleted file mode 100644
index 28ef2d19e1ed..000000000000
--- a/dev-ruby/narray/narray-0.5.9_p6.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.5.9_p6.ebuild,v 1.10 2011/10/23 15:30:21 armin76 Exp $
-
-MY_P=${P/_/}
-
-DESCRIPTION="Numerical N-dimensional Array class"
-HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
-SRC_URI="mirror://rubyforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64 hppa ~mips ppc ~ppc64 x86"
-
-USE_RUBY="ruby18"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- ruby extconf.rb || die
- emake || die
-}
-
-src_install() {
- make exec_prefix=/usr DESTDIR="${D}" install || die
- dodoc ChangeLog README.* SPEC.*
-}
diff --git a/dev-ruby/narray/narray-0.6.0.1-r1.ebuild b/dev-ruby/narray/narray-0.6.0.1-r1.ebuild
deleted file mode 100644
index d1ae1b5d5de0..000000000000
--- a/dev-ruby/narray/narray-0.6.0.1-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.6.0.1-r1.ebuild,v 1.1 2011/12/28 08:31:08 graaff Exp $
-
-EAPI=4
-
-# jruby → native extension
-USE_RUBY="ruby18 ree18 ruby19"
-
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="ChangeLog README.en README.ja SPEC.en SPEC.ja"
-
-RUBY_FAKEGEM_VERSION="${PV/_p/.}"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Numerical N-dimensional Array class"
-HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
-SRC_URI="mirror://rubyforge/${PN}/${P/_/}.tar.gz"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86"
-
-IUSE=""
-
-all_ruby_prepare() {
- # the tests aren't really written to be a testsuite, so the
- # failure cases will literally fail; ignore all of those ad
- # instead expect that the rest won't fail.
- sed -i -e '/[fF]ollowing will fail/,$ s:^:#:' \
- test/*.rb || die "sed failed"
-}
-
-each_ruby_configure() {
- ${RUBY} extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed"
- cp -l ${PN}$(get_modname) lib || die "copy of ${PN}$(get_modname) failed"
-}
-
-each_ruby_test() {
- for unit in test/*; do
- # Skip over the FFTW test because it needs a package we don't
- # have in tree.
- [[ ${unit} == test/testfftw.rb ]] && continue
-
- ${RUBY} -Ilib ${unit} || die "test ${unit} failed"
- done
-}