summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-12-22 20:03:19 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-12-22 20:03:19 +0000
commit90052c50b3fd3290c80b2966827657065372d682 (patch)
treeda05fa371aab39e6163bda32a9b1439e514a7685 /dev-ruby/msgpack
parentamd64 stable, bug #491544 (diff)
downloadgentoo-2-90052c50b3fd3290c80b2966827657065372d682.tar.gz
gentoo-2-90052c50b3fd3290c80b2966827657065372d682.tar.bz2
gentoo-2-90052c50b3fd3290c80b2966827657065372d682.zip
Cleanup old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/msgpack')
-rw-r--r--dev-ruby/msgpack/ChangeLog6
-rw-r--r--dev-ruby/msgpack/msgpack-0.4.7.ebuild39
-rw-r--r--dev-ruby/msgpack/msgpack-0.5.5.ebuild49
3 files changed, 5 insertions, 89 deletions
diff --git a/dev-ruby/msgpack/ChangeLog b/dev-ruby/msgpack/ChangeLog
index 53d8c1680f5d..e4180cfda2f6 100644
--- a/dev-ruby/msgpack/ChangeLog
+++ b/dev-ruby/msgpack/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/msgpack
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/ChangeLog,v 1.22 2013/12/22 18:40:57 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/ChangeLog,v 1.23 2013/12/22 20:03:19 mrueg Exp $
+
+ 22 Dec 2013; Manuel Rüger <mrueg@gentoo.org> -msgpack-0.4.7.ebuild,
+ -msgpack-0.5.5.ebuild:
+ Cleanup old.
22 Dec 2013; Anthony G. Basile <blueness@gentoo.org> msgpack-0.5.7.ebuild:
Keyword ~ppc64, bug #465948
diff --git a/dev-ruby/msgpack/msgpack-0.4.7.ebuild b/dev-ruby/msgpack/msgpack-0.4.7.ebuild
deleted file mode 100644
index 68814ac433b8..000000000000
--- a/dev-ruby/msgpack/msgpack-0.4.7.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/msgpack-0.4.7.ebuild,v 1.3 2013/01/15 02:51:59 zerochaos Exp $
-
-EAPI="3"
-
-# jruby → uses a binary extension
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
-HOMEPAGE="http://msgpack.sourceforge.jp/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE=""
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die "Configuration of extension failed."
-}
-
-each_ruby_compile() {
- emake -Cext || die
-
- mkdir lib || die "Unable to make lib directory."
- cp ext/msgpack.so lib/ || die "Unable to install msgpack library."
-}
-
-each_ruby_test() {
- cd test
- ${RUBY} test_cases.rb || die "tests failed"
- ${RUBY} test_pack_unpack.rb || die "tests failed"
- ${RUBY} test_encoding.rb || die "tests failed"
-}
diff --git a/dev-ruby/msgpack/msgpack-0.5.5.ebuild b/dev-ruby/msgpack/msgpack-0.5.5.ebuild
deleted file mode 100644
index fc012bb1ead0..000000000000
--- a/dev-ruby/msgpack/msgpack-0.5.5.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/msgpack-0.5.5.ebuild,v 1.2 2013/11/19 19:47:55 graaff Exp $
-
-EAPI=5
-
-# jruby → uses a binary extension
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
-HOMEPAGE="http://msgpack.sourceforge.jp/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="doc"
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile || die
-}
-
-each_ruby_prepare() {
- case "${RUBY}" in
- *ruby18)
- # Fix tests as .clear is not available in ruby18
- # Tests are working, but are very slow on ruby18
- sed -i -e 's/s.clear/s.replace ""/' spec/buffer_spec.rb || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
-}
-
-each_ruby_compile() {
- emake -Cext/${PN}
- cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
-}