summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2012-08-11 08:45:09 +0000
committerBenedikt Boehm <hollow@gentoo.org>2012-08-11 08:45:09 +0000
commit230294e6ebca2d3440db2686773275922dc88f89 (patch)
tree64fc3ea01fe508f2749debd2e578717ea6449c8b /dev-ruby/mixlib-shellout
parentAdd internal rhino as we need it. Fixes bug#430800. (diff)
downloadgentoo-2-230294e6ebca2d3440db2686773275922dc88f89.tar.gz
gentoo-2-230294e6ebca2d3440db2686773275922dc88f89.tar.bz2
gentoo-2-230294e6ebca2d3440db2686773275922dc88f89.zip
convert to EAPI4 and add test support
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mixlib-shellout')
-rw-r--r--dev-ruby/mixlib-shellout/ChangeLog5
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild12
2 files changed, 13 insertions, 4 deletions
diff --git a/dev-ruby/mixlib-shellout/ChangeLog b/dev-ruby/mixlib-shellout/ChangeLog
index fc0626417d9a..7d8a51efcc15 100644
--- a/dev-ruby/mixlib-shellout/ChangeLog
+++ b/dev-ruby/mixlib-shellout/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/mixlib-shellout
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/ChangeLog,v 1.1 2012/04/29 13:13:46 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/ChangeLog,v 1.2 2012/08/11 08:45:09 hollow Exp $
+
+ 11 Aug 2012; Benedikt Böhm <hollow@gentoo.org> mixlib-shellout-1.0.0.ebuild:
+ convert to EAPI4 and add test support
*mixlib-shellout-1.0.0 (29 Apr 2012)
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild
index 79d79f409d25..104c9c8d95dc 100644
--- a/dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild
@@ -1,19 +1,25 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild,v 1.1 2012/04/29 13:13:46 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/mixlib-shellout-1.0.0.ebuild,v 1.2 2012/08/11 08:45:09 hollow Exp $
-EAPI="2"
+EAPI=4
USE_RUBY="ruby18 ruby19"
RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_EXTRA_DOC="README.md"
inherit ruby-fakegem
DESCRIPTION="Run external commands on Unix or Windows"
HOMEPAGE="http://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/tarball/${PV} -> ${P}.tgz"
+RUBY_S="opscode-${PN}-*"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"