summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-08-02 01:45:54 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-08-02 01:45:54 +0000
commit7acee66433e6b15a438eff92871b6d0485ef759e (patch)
treeddfe2fbcd0655e9d98c36a3d253eb22a1abe24e0 /dev-ruby/mixlib-authentication
parenttidy (diff)
downloadgentoo-2-7acee66433e6b15a438eff92871b6d0485ef759e.tar.gz
gentoo-2-7acee66433e6b15a438eff92871b6d0485ef759e.tar.bz2
gentoo-2-7acee66433e6b15a438eff92871b6d0485ef759e.zip
Add ruby20 support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/mixlib-authentication')
-rw-r--r--dev-ruby/mixlib-authentication/ChangeLog8
-rw-r--r--dev-ruby/mixlib-authentication/mixlib-authentication-1.3.0-r1.ebuild25
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-ruby/mixlib-authentication/ChangeLog b/dev-ruby/mixlib-authentication/ChangeLog
index 26ab33ef6be8..7b3c2d8f020e 100644
--- a/dev-ruby/mixlib-authentication/ChangeLog
+++ b/dev-ruby/mixlib-authentication/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/mixlib-authentication
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-authentication/ChangeLog,v 1.12 2014/05/13 20:43:49 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-authentication/ChangeLog,v 1.13 2014/08/02 01:45:54 mrueg Exp $
+
+*mixlib-authentication-1.3.0-r1 (02 Aug 2014)
+
+ 02 Aug 2014; Manuel Rüger <mrueg@gentoo.org>
+ +mixlib-authentication-1.3.0-r1.ebuild:
+ Add ruby20 support.
13 May 2014; Manuel Rüger <mrueg@gentoo.org>
mixlib-authentication-1.3.0.ebuild:
diff --git a/dev-ruby/mixlib-authentication/mixlib-authentication-1.3.0-r1.ebuild b/dev-ruby/mixlib-authentication/mixlib-authentication-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..8ce8470cc224
--- /dev/null
+++ b/dev-ruby/mixlib-authentication/mixlib-authentication-1.3.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-authentication/mixlib-authentication-1.3.0-r1.ebuild,v 1.1 2014/08/02 01:45:54 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRADOC="NOTICE README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mixes in simple per-request authentication"
+HOMEPAGE="http://github.com/opscode/mixlib-authentication"
+SRC_URI="https://github.com/opscode/${PN}/tarball/${PV} -> ${P}.tgz"
+RUBY_S="opscode-${PN}-*"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/mixlib-log"