summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-17 11:35:01 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-17 11:35:01 +0000
commit51752b2ad205c43fc2f5bb9ca76af99657e984ec (patch)
treeb38ed0f6ade0624de2087b761bc5ad295ece4588 /dev-ruby/mime-types
parentVersion bump. Update dependencies. Add ruby20. (diff)
downloadgentoo-2-51752b2ad205c43fc2f5bb9ca76af99657e984ec.tar.gz
gentoo-2-51752b2ad205c43fc2f5bb9ca76af99657e984ec.tar.bz2
gentoo-2-51752b2ad205c43fc2f5bb9ca76af99657e984ec.zip
Version bump. Drop jruby since the code is no longer compatible with ruby 1.8 syntax.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/mime-types')
-rw-r--r--dev-ruby/mime-types/ChangeLog8
-rw-r--r--dev-ruby/mime-types/mime-types-2.2.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/mime-types/ChangeLog b/dev-ruby/mime-types/ChangeLog
index 9d9a2bddc5cf..f6ca7638509b 100644
--- a/dev-ruby/mime-types/ChangeLog
+++ b/dev-ruby/mime-types/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/mime-types
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mime-types/ChangeLog,v 1.49 2014/04/20 17:03:07 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mime-types/ChangeLog,v 1.50 2014/05/17 11:35:01 graaff Exp $
+
+*mime-types-2.2 (17 May 2014)
+
+ 17 May 2014; Hans de Graaff <graaff@gentoo.org> +mime-types-2.2.ebuild:
+ Version bump. Drop jruby since the code is no longer compatible with ruby 1.8
+ syntax.
20 Apr 2014; Manuel Rüger <mrueg@gentoo.org>
-files/mime-types-1.18-linux-tests.patch, -mime-types-1.19.ebuild:
diff --git a/dev-ruby/mime-types/mime-types-2.2.ebuild b/dev-ruby/mime-types/mime-types-2.2.ebuild
new file mode 100644
index 000000000000..9f059f1565cd
--- /dev/null
+++ b/dev-ruby/mime-types/mime-types-2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mime-types/mime-types-2.2.ebuild,v 1.1 2014/05/17 11:35:01 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a mailcap-like MIME Content-Type lookup for Ruby."
+HOMEPAGE="http://rubyforge.org/projects/mime-types"
+
+LICENSE="MIT Artistic GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ # Handle minitest ourselves to avoid bundler dependency.
+ sed -i -e '2igem "minitest", "~> 5.0"; require "minitest/autorun"' test/test_*.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test/test_*.rb || die
+}