summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-04-05 23:08:26 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-04-05 23:08:26 +0000
commit0d096fc85dbf09fb9da9aea82fc08d2889151fd0 (patch)
tree3ff466747afd7ba288890fb0688424454ccaf5c7 /dev-ruby/map
parentRemove ruby18 target. (diff)
downloadgentoo-2-0d096fc85dbf09fb9da9aea82fc08d2889151fd0.tar.gz
gentoo-2-0d096fc85dbf09fb9da9aea82fc08d2889151fd0.tar.bz2
gentoo-2-0d096fc85dbf09fb9da9aea82fc08d2889151fd0.zip
Remove ruby18 target. Cleanup old.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/map')
-rw-r--r--dev-ruby/map/ChangeLog6
-rw-r--r--dev-ruby/map/files/ruby18-failing-tests.patch15
-rw-r--r--dev-ruby/map/map-6.5.2.ebuild36
-rw-r--r--dev-ruby/map/map-6.5.3.ebuild8
4 files changed, 7 insertions, 58 deletions
diff --git a/dev-ruby/map/ChangeLog b/dev-ruby/map/ChangeLog
index 065847ef2a2b..50132b0419a0 100644
--- a/dev-ruby/map/ChangeLog
+++ b/dev-ruby/map/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/map
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/ChangeLog,v 1.14 2014/03/08 02:08:56 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/ChangeLog,v 1.15 2014/04/05 23:08:26 mrueg Exp $
+
+ 05 Apr 2014; Manuel Rüger <mrueg@gentoo.org>
+ -files/ruby18-failing-tests.patch, -map-6.5.2.ebuild, map-6.5.3.ebuild:
+ Remove ruby18 target. Cleanup old.
08 Mar 2014; Manuel Rüger <mrueg@gentoo.org> -map-5.5.0.ebuild,
-map-6.5.1.ebuild:
diff --git a/dev-ruby/map/files/ruby18-failing-tests.patch b/dev-ruby/map/files/ruby18-failing-tests.patch
deleted file mode 100644
index c0a608ff6aff..000000000000
--- a/dev-ruby/map/files/ruby18-failing-tests.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- test/map_test.rb.old 2013-10-14 15:37:25.639883829 +0000
-+++ test/map_test.rb 2013-10-14 15:37:33.747781899 +0000
-@@ -651,12 +651,6 @@
- assert{ all_args == [[1, 2], [3, 4]] }
- end
-
-- testing 'keeps every entry for which block is true and returns self' do
-- m = Map.new( { :a => 1 , :b => 2 , :c => 3 , :d => 4 } )
-- assert{ m.keep_if { |k,v| v % 2 == 0 }.object_id == m.object_id }
-- assert{ m == Map.new( { :b => 2 , :d => 4 } ) }
-- end
--
- testing 'it raises a RuntimeError if called on a frozen instance' do
- m = Map.new( { :a => 1 } ).freeze
-
diff --git a/dev-ruby/map/map-6.5.2.ebuild b/dev-ruby/map/map-6.5.2.ebuild
deleted file mode 100644
index 4f9e84bd1f4b..000000000000
--- a/dev-ruby/map/map-6.5.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/map-6.5.2.ebuild,v 1.1 2014/02/14 10:31:28 mrueg Exp $
-
-EAPI=5
-USE_RUBY="ruby18 ruby19 ruby20 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="README"
-
-RUBY_FAKEGEM_GEMSPEC="map.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A string/symbol indifferent ordered hash that works in all rubies."
-HOMEPAGE="http://github.com/ahoward/map"
-
-LICENSE="|| ( Ruby BSD-2 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE=""
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby18)
- epatch "${FILESDIR}/ruby18-failing-tests.patch"
- epatch "${FILESDIR}/${PN}-6.5.1-ruby18-failing-tests.patch"
- ;;
- *jruby)
- epatch "${FILESDIR}/${PN}-6.5.1-ruby18-failing-tests.patch"
- ;;
- *)
- ;;
- esac
-}
diff --git a/dev-ruby/map/map-6.5.3.ebuild b/dev-ruby/map/map-6.5.3.ebuild
index 1c348413c915..6df1fa187f6e 100644
--- a/dev-ruby/map/map-6.5.3.ebuild
+++ b/dev-ruby/map/map-6.5.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/map-6.5.3.ebuild,v 1.1 2014/02/23 16:17:06 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/map-6.5.3.ebuild,v 1.2 2014/04/05 23:08:26 mrueg Exp $
EAPI=5
-USE_RUBY="ruby18 ruby19 ruby20 jruby"
+USE_RUBY="ruby19 ruby20 jruby"
RUBY_FAKEGEM_TASK_DOC=""
@@ -23,10 +23,6 @@ IUSE=""
each_ruby_prepare() {
case ${RUBY} in
- *ruby18)
- epatch "${FILESDIR}/ruby18-failing-tests.patch"
- epatch "${FILESDIR}/${PN}-6.5.1-ruby18-failing-tests.patch"
- ;;
*jruby)
epatch "${FILESDIR}/${PN}-6.5.1-ruby18-failing-tests.patch"
;;