summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 04:18:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 04:18:14 +0000
commit0e5fcba7f75d9af6eeca0ac44a80d3a7a306cfc3 (patch)
tree11283385d33e5b757fb34b02b62e236c43da4a45 /dev-ruby/mail/mail-2.3.3.ebuild
parentPort to rspec helper for testing. (diff)
downloadgentoo-2-0e5fcba7f75d9af6eeca0ac44a80d3a7a306cfc3.tar.gz
gentoo-2-0e5fcba7f75d9af6eeca0ac44a80d3a7a306cfc3.tar.bz2
gentoo-2-0e5fcba7f75d9af6eeca0ac44a80d3a7a306cfc3.zip
Use the new rspec recipe for testing; on 2.3.3 this also changes the test dep from rspec:0 to rspec:2, but keeps a rspec:2 dependency for documentation.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mail/mail-2.3.3.ebuild')
-rw-r--r--dev-ruby/mail/mail-2.3.3.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-ruby/mail/mail-2.3.3.ebuild b/dev-ruby/mail/mail-2.3.3.ebuild
index b1674d65f0d7..2a19145b2144 100644
--- a/dev-ruby/mail/mail-2.3.3.ebuild
+++ b/dev-ruby/mail/mail-2.3.3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mail/mail-2.3.3.ebuild,v 1.2 2012/08/10 06:13:08 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mail/mail-2.3.3.ebuild,v 1.3 2012/08/14 04:18:14 flameeyes Exp $
EAPI=4
USE_RUBY="ruby18 ruby19 ree18"
-RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_DOCDIR="rdoc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc TODO.rdoc"
@@ -33,8 +33,7 @@ ruby_add_rdepend "
>=dev-ruby/mime-types-1.16
>=dev-ruby/treetop-1.4.8"
-ruby_add_bdepend "doc? ( dev-ruby/rspec:0 )
- test? ( dev-ruby/rspec:0 )"
+ruby_add_bdepend "doc? ( dev-ruby/rspec:0 )"
all_ruby_prepare() {
sed -i -e '/[Bb]undle/d' -e '6d' Rakefile || die "Unable to remove Bundler code."