summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-08 06:34:17 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-08 06:34:17 +0000
commit99f521aae96b9d605a7a929a056bebd40667f1c6 (patch)
tree51e5342e9cc9536ef5b4c95d9ad50cc4caf55e6f /dev-ruby/httpclient
parentFix ps segfault on x32 ABI. (diff)
downloadgentoo-2-99f521aae96b9d605a7a929a056bebd40667f1c6.tar.gz
gentoo-2-99f521aae96b9d605a7a929a056bebd40667f1c6.tar.bz2
gentoo-2-99f521aae96b9d605a7a929a056bebd40667f1c6.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/ChangeLog7
-rw-r--r--dev-ruby/httpclient/httpclient-2.2.4.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/httpclient/ChangeLog b/dev-ruby/httpclient/ChangeLog
index 4132e8fb5996..19cab206eeec 100644
--- a/dev-ruby/httpclient/ChangeLog
+++ b/dev-ruby/httpclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/httpclient
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.28 2011/10/17 06:35:21 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.29 2011/12/08 06:34:17 graaff Exp $
+
+*httpclient-2.2.4 (08 Dec 2011)
+
+ 08 Dec 2011; Hans de Graaff <graaff@gentoo.org> +httpclient-2.2.4.ebuild:
+ Version bump.
*httpclient-2.2.2 (17 Oct 2011)
diff --git a/dev-ruby/httpclient/httpclient-2.2.4.ebuild b/dev-ruby/httpclient/httpclient-2.2.4.ebuild
new file mode 100644
index 000000000000..b666a84d6c78
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.2.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.2.4.ebuild,v 1.1 2011/12/08 06:34:17 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="https://github.com/nahi/httpclient"
+SRC_URI="https://github.com/nahi/httpclient/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="nahi-httpclient-*"
+
+LICENSE="Ruby"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ !dev-ruby/http-access2"
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare () {
+ rm Gemfile || die
+ sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
+}
+
+each_ruby_prepare() {
+ # Don't run two tests that are known to fail with jruby. This is a
+ # bug in jruby that won't be fixed until jruby 1.7.
+ # https://github.com/nahi/httpclient/issues/61
+ case ${RUBY} in
+ *jruby)
+ sed -i -e '/test_get_gzipped_content/,/end/s:^:#:' \
+ -e '/test_socket_local/,/^ end/s:^:#:' \
+ test/test_httpclient.rb
+ ;;
+ *)
+ ;;
+ esac
+}