summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-06-08 07:37:40 +0000
committerHans de Graaff <graaff@gentoo.org>2014-06-08 07:37:40 +0000
commit83b0c0786779ee77e4c55504dbf06904b65c3208 (patch)
tree6b0f468ddffaefbbacaf770db910a2d4fa5e9eb4 /dev-ruby/httpclient
parentAdd workaround for systems that do not have a UTF-8 locale set, bug 512594. (diff)
downloadgentoo-2-83b0c0786779ee77e4c55504dbf06904b65c3208.tar.gz
gentoo-2-83b0c0786779ee77e4c55504dbf06904b65c3208.tar.bz2
gentoo-2-83b0c0786779ee77e4c55504dbf06904b65c3208.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/ChangeLog7
-rw-r--r--dev-ruby/httpclient/httpclient-2.4.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-ruby/httpclient/ChangeLog b/dev-ruby/httpclient/ChangeLog
index 4ad68443a641..eb362fd423a1 100644
--- a/dev-ruby/httpclient/ChangeLog
+++ b/dev-ruby/httpclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/httpclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.53 2014/04/18 12:05:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.54 2014/06/08 07:37:40 graaff Exp $
+
+*httpclient-2.4.0 (08 Jun 2014)
+
+ 08 Jun 2014; Hans de Graaff <graaff@gentoo.org> +httpclient-2.4.0.ebuild:
+ Version bump.
18 Apr 2014; Hans de Graaff <graaff@gentoo.org> httpclient-2.3.4.1-r1.ebuild:
Add ruby21.
diff --git a/dev-ruby/httpclient/httpclient-2.4.0.ebuild b/dev-ruby/httpclient/httpclient-2.4.0.ebuild
new file mode 100644
index 000000000000..e4457798af43
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.4.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.4.0.ebuild,v 1.1 2014/06/08 07:37:40 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="https://github.com/nahi/httpclient"
+SRC_URI="https://github.com/nahi/httpclient/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="Ruby"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ !dev-ruby/http-access2"
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare () {
+ rm Gemfile || die
+ sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
+
+ # Fix documentation task
+ sed -i -e 's/README.txt/README.md/' Rakefile || die
+
+ # Remove mandatory CI reports since we don't need this for testing.
+ sed -i -e '/reporter/s:^:#:' Rakefile || die
+
+ # Remove mandatory simplecov dependency
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die
+
+ # Comment out test requiring network access that makes assumptions
+ # about the environment, bug 395155
+ sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
+
+ # Skip tests using rack-ntlm which is not packaged. Weirdly these
+ # only fail on jruby.
+ rm test/test_auth.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test/test_*.rb || die
+}