summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-08-28 07:42:22 +0000
committerHans de Graaff <graaff@gentoo.org>2010-08-28 07:42:22 +0000
commita0db2a0f7d6db877bb460a811908983188ed7118 (patch)
tree0cc41aba26b8449a5442ddc21c98fb5891c8cc0d /dev-ruby/hoe
parentVersion bump (diff)
downloadgentoo-2-a0db2a0f7d6db877bb460a811908983188ed7118.tar.gz
gentoo-2-a0db2a0f7d6db877bb460a811908983188ed7118.tar.bz2
gentoo-2-a0db2a0f7d6db877bb460a811908983188ed7118.zip
Fix file ordering issues with tests, fixing bug 323059.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/hoe')
-rw-r--r--dev-ruby/hoe/ChangeLog6
-rw-r--r--dev-ruby/hoe/files/hoe-2.6.1-test-file-ordering.patch18
-rw-r--r--dev-ruby/hoe/hoe-2.6.1.ebuild4
3 files changed, 26 insertions, 2 deletions
diff --git a/dev-ruby/hoe/ChangeLog b/dev-ruby/hoe/ChangeLog
index f1544735b1f9..86e1b79a70e8 100644
--- a/dev-ruby/hoe/ChangeLog
+++ b/dev-ruby/hoe/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/hoe
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.88 2010/08/22 16:40:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.89 2010/08/28 07:42:22 graaff Exp $
+
+ 28 Aug 2010; Hans de Graaff <graaff@gentoo.org> hoe-2.6.1.ebuild,
+ +files/hoe-2.6.1-test-file-ordering.patch:
+ Fix file ordering issues with tests, fixing bug 323059.
22 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org> hoe-2.6.0-r1.ebuild:
Remove ruby19/ree18 support from 2.6.0-r1 so that it can be marked stable.
diff --git a/dev-ruby/hoe/files/hoe-2.6.1-test-file-ordering.patch b/dev-ruby/hoe/files/hoe-2.6.1-test-file-ordering.patch
new file mode 100644
index 000000000000..130715062d36
--- /dev/null
+++ b/dev-ruby/hoe/files/hoe-2.6.1-test-file-ordering.patch
@@ -0,0 +1,18 @@
+--- test/test_hoe_gemcutter.rb.orig 2010-08-28 09:35:26.129730713 +0200
++++ test/test_hoe_gemcutter.rb 2010-08-28 09:35:53.673730929 +0200
+@@ -1,3 +1,4 @@
++require "hoe"
+ require "hoe/gemcutter" unless defined? Hoe::Gemcutter
+
+ class TestHoeGemcutter < MiniTest::Unit::TestCase
+--- test/test_hoe.rb.orig 2010-08-28 09:35:34.929980884 +0200
++++ test/test_hoe.rb 2010-08-28 09:37:21.978230874 +0200
+@@ -49,7 +49,7 @@
+ assert_equal 'blah', spec.rubyforge_project
+ assert_equal Gem::RubyGemsVersion, spec.rubygems_version
+ assert_match(/^Hoe.*Rakefiles$/, spec.summary)
+- assert_equal files.grep(/^test/), spec.test_files
++ assert_equal files.grep(/^test/), spec.test_files.sort
+
+ deps = spec.dependencies.sort_by { |dep| dep.name }
+
diff --git a/dev-ruby/hoe/hoe-2.6.1.ebuild b/dev-ruby/hoe/hoe-2.6.1.ebuild
index 8c7aec1c6016..5c877b4d5d1e 100644
--- a/dev-ruby/hoe/hoe-2.6.1.ebuild
+++ b/dev-ruby/hoe/hoe-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.6.1.ebuild,v 1.3 2010/08/18 11:05:02 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.6.1.ebuild,v 1.4 2010/08/28 07:42:22 graaff Exp $
EAPI=2
USE_RUBY="ruby18 ree18 ruby19 jruby"
@@ -22,6 +22,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE=""
+RUBY_PATCHES=( "${P}-test-file-ordering.patch" )
+
# - also requires dev-ruby/hoe-seattlerb for 1.9;
# - dev-ruby/gemcutter is an optional dependency at both runtime and
# test-time, at least for us;