summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-03-21 10:39:11 +0000
committerHans de Graaff <graaff@gentoo.org>2014-03-21 10:39:11 +0000
commit2f497f4676c74ee4e4b1b099f076bd0e9605a48d (patch)
tree772a6658dc11134201303b33a973f3214e16c7ae /dev-ruby/hoe-seattlerb
parentremove old (diff)
downloadgentoo-2-2f497f4676c74ee4e4b1b099f076bd0e9605a48d.tar.gz
gentoo-2-2f497f4676c74ee4e4b1b099f076bd0e9605a48d.tar.bz2
gentoo-2-2f497f4676c74ee4e4b1b099f076bd0e9605a48d.zip
Revision bump for ruby21 support.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/hoe-seattlerb')
-rw-r--r--dev-ruby/hoe-seattlerb/ChangeLog8
-rw-r--r--dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r2.ebuild27
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/hoe-seattlerb/ChangeLog b/dev-ruby/hoe-seattlerb/ChangeLog
index e8ef24eb6e71..c426b3bc6491 100644
--- a/dev-ruby/hoe-seattlerb/ChangeLog
+++ b/dev-ruby/hoe-seattlerb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/hoe-seattlerb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe-seattlerb/ChangeLog,v 1.56 2014/02/01 01:29:58 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe-seattlerb/ChangeLog,v 1.57 2014/03/21 10:39:11 graaff Exp $
+
+*hoe-seattlerb-1.3.2-r2 (21 Mar 2014)
+
+ 21 Mar 2014; Hans de Graaff <graaff@gentoo.org>
+ +hoe-seattlerb-1.3.2-r2.ebuild:
+ Revision bump for ruby21 support.
01 Feb 2014; Akinori Hattori <hattya@gentoo.org>
hoe-seattlerb-1.3.2-r1.ebuild:
diff --git a/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r2.ebuild b/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r2.ebuild
new file mode 100644
index 000000000000..c786d75210e3
--- /dev/null
+++ b/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.2-r2.ebuild,v 1.1 2014/03/21 10:39:11 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+# no tests present
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe plugins providing tasks used by seattle.rb"
+HOMEPAGE="http://seattlerb.rubyforge.org/hoe-seattlerb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Not a real fix, but otherwise USE="doc" breaks and defaulte license is MIT
+ sed -i -e "/license/d" Rakefile || die
+}