summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-20 18:49:47 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-20 18:49:47 +0000
commit56e15686eab5dca34d027755dae10aad09b71c9d (patch)
treef9d1a10fdab546a0436c4444fb12b83964d47a84 /dev-ruby/gherkin
parentAdd ruby20, ruby21. (diff)
downloadgentoo-2-56e15686eab5dca34d027755dae10aad09b71c9d.tar.gz
gentoo-2-56e15686eab5dca34d027755dae10aad09b71c9d.tar.bz2
gentoo-2-56e15686eab5dca34d027755dae10aad09b71c9d.zip
Add ruby20. Drop arm, ia64 due to bug 510876.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/gherkin')
-rw-r--r--dev-ruby/gherkin/ChangeLog7
-rw-r--r--dev-ruby/gherkin/gherkin-2.12.0-r2.ebuild91
2 files changed, 97 insertions, 1 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index 2e746ab6615f..f3ac29c06ba1 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gherkin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.62 2014/04/24 17:35:33 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.63 2014/05/20 18:49:47 graaff Exp $
+
+*gherkin-2.12.0-r2 (20 May 2014)
+
+ 20 May 2014; Hans de Graaff <graaff@gentoo.org> +gherkin-2.12.0-r2.ebuild:
+ Add ruby20. Drop arm, ia64 due to bug 510876.
24 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -gherkin-2.12.0.ebuild,
gherkin-2.11.6.ebuild, gherkin-2.12.0-r1.ebuild:
diff --git a/dev-ruby/gherkin/gherkin-2.12.0-r2.ebuild b/dev-ruby/gherkin/gherkin-2.12.0-r2.ebuild
new file mode 100644
index 000000000000..57f567669570
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-2.12.0-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.12.0-r2.ebuild,v 1.1 2014/05/20 18:49:47 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
+HOMEPAGE="https://github.com/cucumber/gherkin"
+LICENSE="MIT"
+SRC_URI="https://github.com/cucumber/gherkin/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="${DEPEND} dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ test? (
+ >=dev-ruby/builder-2.1.2
+ >=dev-util/cucumber-1.1.3
+ >=dev-ruby/rspec-2.6.0
+ >=dev-ruby/term-ansicolor-1.0.5
+ )
+ doc? ( >=dev-ruby/yard-0.8.3 )"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.3"
+
+all_ruby_prepare() {
+ # Remove Bundler-related things.
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
+ rm Gemfile || die
+
+ # Don't use compile dependencies to avoid building again for specs.
+ sed -i -e '/:compile/d' Rakefile
+
+ # Keep this hardcoded -O0 optimization level since
+ # https://github.com/cucumber/gherkin/issues/182#issuecomment-6945009
+ # hints at the fact that removing it might cause the mysterious
+ # Lexer errors that hapen intermittently.
+ # sed -ie -e 's/-O0//' tasks/compile.rake || die
+
+ # Remove feature that depends on direct access to the cucumber
+ # source. We could probably set this up by downloading the source
+ # and unpacking it, but skipping this now in the interest of time.
+ rm features/pretty_formatter.feature || die
+
+ # We need to remove these tasks during bootstrapping since it tries
+ # to load cucumber already but we can be sure it isn't installed
+ # yet. Also remove other rake tasks for which we may not yet have
+ # dependencies.
+ if ! use test ; then
+ rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
+ fi
+
+ # Avoid dependency on yard if USE=-doc
+ if ! use doc ; then
+ rm tasks/apidoc.rake || die
+ fi
+
+ # Avoid implicit dependency on git
+ sed -i -e 's/git ls-files/echo/' gherkin.gemspec || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die
+ fi
+}
+
+each_ruby_compile() {
+ ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I lib -S rake spec || die "Specs failed"
+ CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
+}