summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-11-17 12:07:02 +0000
committerHans de Graaff <graaff@gentoo.org>2013-11-17 12:07:02 +0000
commit4ceb38f52134cb5120ccb0a098f4a2a1984fe622 (patch)
tree6ed3e3318420d76842b55a06413912a493924b7c /dev-ruby/erubis
parentRemove older unstables (diff)
downloadgentoo-2-4ceb38f52134cb5120ccb0a098f4a2a1984fe622.tar.gz
gentoo-2-4ceb38f52134cb5120ccb0a098f4a2a1984fe622.tar.bz2
gentoo-2-4ceb38f52134cb5120ccb0a098f4a2a1984fe622.zip
Add ruby20. Work around even more brokenness in the tests with more recent jruby and ruby:1.8 versions.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/erubis')
-rw-r--r--dev-ruby/erubis/ChangeLog8
-rw-r--r--dev-ruby/erubis/erubis-2.7.0-r1.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-ruby/erubis/ChangeLog b/dev-ruby/erubis/ChangeLog
index 794e5eef39c3..f9519591a35e 100644
--- a/dev-ruby/erubis/ChangeLog
+++ b/dev-ruby/erubis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/erubis
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/erubis/ChangeLog,v 1.24 2013/07/27 22:21:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/erubis/ChangeLog,v 1.25 2013/11/17 12:07:02 graaff Exp $
+
+*erubis-2.7.0-r1 (17 Nov 2013)
+
+ 17 Nov 2013; Hans de Graaff <graaff@gentoo.org> +erubis-2.7.0-r1.ebuild:
+ Add ruby20. Work around even more brokenness in the tests with more recent
+ jruby and ruby:1.8 versions.
27 Jul 2013; Agostino Sarubbo <ago@gentoo.org> erubis-2.7.0.ebuild:
Stable for x86, wrt bug #477454
diff --git a/dev-ruby/erubis/erubis-2.7.0-r1.ebuild b/dev-ruby/erubis/erubis-2.7.0-r1.ebuild
new file mode 100644
index 000000000000..81e785bc119a
--- /dev/null
+++ b/dev-ruby/erubis/erubis-2.7.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/erubis/erubis-2.7.0-r1.ebuild,v 1.1 2013/11/17 12:07:02 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Erubis is an implementation of eRuby"
+HOMEPAGE="http://www.kuwata-lab.com/erubis/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/abstract-1.0.0"
+
+all_ruby_prepare() {
+ # These tests now fail due to other ordering and fact that sym
+ # are now returned.
+ rm test/test-users-guide.rb || die
+ sed -i -e '/test-users-guide/ s:^:#:' test/test.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Avoid test on jruby that fails different on syntax error.
+ sed -i -e '/test_syntax2/,/^ end/ s:^:#:' test/test-main.rb || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ # http://rubyforge.org/tracker/index.php?func=detail&aid=29484&group_id=1320&atid=5201
+ *ruby19)
+ einfo "Tests are not compatible with ruby 1.9.3 with Psych as YAML module."
+ ;;
+ *ruby20)
+ einfo "Tests are not compatible with ruby 1.9.3 with Psych as YAML module."
+ ;;
+ *)
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -I. test/test.rb || die
+ ;;
+ esac
+}