summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-05 23:49:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-05 23:49:05 +0000
commitdf98f9547f108501860064a147c34cfd317326bf (patch)
tree7a10d7fca645cd233d5e22146f48e4ddafec1ca8 /dev-ruby/coderay
parentVersion bump. (diff)
downloadgentoo-2-df98f9547f108501860064a147c34cfd317326bf.tar.gz
gentoo-2-df98f9547f108501860064a147c34cfd317326bf.tar.bz2
gentoo-2-df98f9547f108501860064a147c34cfd317326bf.zip
Version bump; reinstate jruby support.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/coderay')
-rw-r--r--dev-ruby/coderay/ChangeLog8
-rw-r--r--dev-ruby/coderay/coderay-1.0.7.ebuild39
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-ruby/coderay/ChangeLog b/dev-ruby/coderay/ChangeLog
index ce1a74be95f7..4ed94d753215 100644
--- a/dev-ruby/coderay/ChangeLog
+++ b/dev-ruby/coderay/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/coderay
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.52 2012/06/25 06:06:31 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.53 2012/07/05 23:49:05 flameeyes Exp $
+
+*coderay-1.0.7 (05 Jul 2012)
+
+ 05 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> +coderay-1.0.7.ebuild:
+ Version bump; reinstate jruby support.
25 Jun 2012; Hans de Graaff <graaff@gentoo.org> coderay-1.0.6.ebuild:
Avoid unneeded dependency on git.
@@ -210,4 +215,3 @@
16 Jan 2008; Aggelos Orfanakos <agorf@gentoo.org> +metadata.xml,
+coderay-0.7.4.215.ebuild:
Initial import.
-
diff --git a/dev-ruby/coderay/coderay-1.0.7.ebuild b/dev-ruby/coderay/coderay-1.0.7.ebuild
new file mode 100644
index 000000000000..d0e8e5be3259
--- /dev/null
+++ b/dev-ruby/coderay/coderay-1.0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-1.0.7.ebuild,v 1.1 2012/07/05 23:49:05 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+# The test target also contains test:exe but that requires
+# shoulda-context which we do not have packaged yet.
+RUBY_FAKEGEM_TASK_TEST="test:functional test:units"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="Changes-pre-1.0.textile Changes.textile FOLDERS README_INDEX.rdoc README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting."
+HOMEPAGE="http://coderay.rubychan.de/"
+SRC_URI="https://github.com/rubychan/coderay/tarball/v${PV} -> ${P}.tgz"
+
+RUBY_S="rubychan-coderay-*"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Redcloth is optional but automagically tested, so we add this
+# dependency to ensure that we get at least a version that works: bug
+# 330621. We use this convoluted way because redcloth isn't available
+# yet for jruby.
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( >=dev-ruby/redcloth-4.2.2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/ s:^:#:' coderay.gemspec || die
+}