summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-09-02 06:01:17 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-09-02 06:01:17 +0000
commit7277ead9756a78335a9fd48e96ff1f406ea17277 (patch)
tree138a7c433fe3bfbf100f5163e94471e7ea8bffee /dev-ruby/coderay
parentVersion bump (diff)
downloadgentoo-2-7277ead9756a78335a9fd48e96ff1f406ea17277.tar.gz
gentoo-2-7277ead9756a78335a9fd48e96ff1f406ea17277.tar.bz2
gentoo-2-7277ead9756a78335a9fd48e96ff1f406ea17277.zip
Fix license change in stable. Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/coderay')
-rw-r--r--dev-ruby/coderay/ChangeLog8
-rw-r--r--dev-ruby/coderay/coderay-1.0.9.ebuild6
-rw-r--r--dev-ruby/coderay/coderay-1.1.0.ebuild39
3 files changed, 49 insertions, 4 deletions
diff --git a/dev-ruby/coderay/ChangeLog b/dev-ruby/coderay/ChangeLog
index b630ce510b1b..af03b9a8ad01 100644
--- a/dev-ruby/coderay/ChangeLog
+++ b/dev-ruby/coderay/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/coderay
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.74 2013/08/14 07:15:13 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.75 2013/09/02 06:01:17 mrueg Exp $
+
+*coderay-1.1.0 (02 Sep 2013)
+
+ 02 Sep 2013; Manuel Rüger <mrueg@gentoo.org> +coderay-1.1.0.ebuild,
+ coderay-1.0.9.ebuild:
+ Fix license change in stable. Version bump.
14 Aug 2013; Manuel Rüger <mrueg@gentoo.org> -coderay-1.0.6.ebuild,
-coderay-1.0.8.ebuild:
diff --git a/dev-ruby/coderay/coderay-1.0.9.ebuild b/dev-ruby/coderay/coderay-1.0.9.ebuild
index 9ffd22652d8e..f7da41f50fc8 100644
--- a/dev-ruby/coderay/coderay-1.0.9.ebuild
+++ b/dev-ruby/coderay/coderay-1.0.9.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-1.0.9.ebuild,v 1.10 2013/08/08 19:28:04 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-1.0.9.ebuild,v 1.11 2013/09/02 06:01:17 mrueg Exp $
EAPI=4
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ruby19 jruby"
# The test target also contains test:exe but that requires
# shoulda-context which we do not have packaged yet.
@@ -23,7 +23,7 @@ SRC_URI="https://github.com/rubychan/coderay/tarball/v${PV} -> ${P}.tgz"
RUBY_S="rubychan-coderay-*"
-LICENSE="LGPL-2.1"
+LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
diff --git a/dev-ruby/coderay/coderay-1.1.0.ebuild b/dev-ruby/coderay/coderay-1.1.0.ebuild
new file mode 100644
index 000000000000..c31bf77dc14b
--- /dev/null
+++ b/dev-ruby/coderay/coderay-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-1.1.0.ebuild,v 1.1 2013/09/02 06:01:17 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+# The test target also contains test:exe but that requires
+# shoulda-context which we do not have packaged yet.
+RUBY_FAKEGEM_TASK_TEST="test:functional test:units"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="Changes-pre-1.0.textile Changes.textile FOLDERS README_INDEX.rdoc README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting."
+HOMEPAGE="http://coderay.rubychan.de/"
+SRC_URI="https://github.com/rubychan/coderay/tarball/v${PV} -> ${P}.tgz"
+
+RUBY_S="rubychan-coderay-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Redcloth is optional but automagically tested, so we add this
+# dependency to ensure that we get at least a version that works: bug
+# 330621. We use this convoluted way because redcloth isn't available
+# yet for jruby.
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( >=dev-ruby/redcloth-4.2.2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/ s:^:#:' coderay.gemspec || die
+}