summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-15 15:09:31 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-15 15:09:31 +0000
commite8d35d1cd037aabcce2f9eeb4dc274216383bf9a (patch)
tree39828aed011cd61cf5b13aa6de5d1d47eebdc5be /dev-ruby/bluecloth
parentalpha/ia64/sh/sparc stable wrt #282290 (diff)
downloadgentoo-2-e8d35d1cd037aabcce2f9eeb4dc274216383bf9a.tar.gz
gentoo-2-e8d35d1cd037aabcce2f9eeb4dc274216383bf9a.tar.bz2
gentoo-2-e8d35d1cd037aabcce2f9eeb4dc274216383bf9a.zip
Add ruby-fakegem based ebuild for bluecloth; keywords dropped because of build dependency over rdoc.
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/bluecloth')
-rw-r--r--dev-ruby/bluecloth/ChangeLog9
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.0.5-r1.ebuild43
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/bluecloth/ChangeLog b/dev-ruby/bluecloth/ChangeLog
index 170cb16acfc5..e945c1c1425f 100644
--- a/dev-ruby/bluecloth/ChangeLog
+++ b/dev-ruby/bluecloth/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/bluecloth
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.24 2009/11/29 14:33:44 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.25 2009/12/15 15:09:31 flameeyes Exp $
+
+*bluecloth-2.0.5-r1 (15 Dec 2009)
+
+ 15 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +bluecloth-2.0.5-r1.ebuild:
+ Add ruby-fakegem based ebuild for bluecloth; keywords dropped because of
+ build dependency over rdoc.
29 Nov 2009; Alex Legler <a3li@gentoo.org> bluecloth-1.0.0.ebuild:
Fix SRC_URI
diff --git a/dev-ruby/bluecloth/bluecloth-2.0.5-r1.ebuild b/dev-ruby/bluecloth/bluecloth-2.0.5-r1.ebuild
new file mode 100644
index 000000000000..6e97fabe1fc8
--- /dev/null
+++ b/dev-ruby/bluecloth/bluecloth-2.0.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.0.5-r1.ebuild,v 1.1 2009/12/15 15:09:31 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A Ruby implementation of Markdown"
+HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
+SRC_URI="http://www.deveiate.org/code/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/rdoc-2.4.1"
+ruby_add_bdepend test "dev-ruby/rspec
+ dev-ruby/diff-lcs"
+
+each_ruby_compile() {
+ ${RUBY} -S rake ext/Makefile || die
+
+ emake -C ext || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ ruby_fakegem_newins ext/bluecloth_ext.so lib/bluecloth_ext.so
+}
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper bluecloth
+ dodoc ChangeLog README || die
+
+ if use doc; then
+ pushd docs/api
+ dohtml -r * || die
+ popd
+ fi
+}