summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-27 01:29:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-27 01:29:46 +0000
commitff235b445e694b4f9e341a7132b32e49d6b3b8b6 (patch)
treeb4f2a1282702599dd5a2b30d5ab3689df87b122a /dev-ruby/aws-sdk
parentBump to TeX Live 2012. (diff)
downloadgentoo-2-ff235b445e694b4f9e341a7132b32e49d6b3b8b6.tar.gz
gentoo-2-ff235b445e694b4f9e341a7132b32e49d6b3b8b6.tar.bz2
gentoo-2-ff235b445e694b4f9e341a7132b32e49d6b3b8b6.zip
Version bump (my patch has been merged).
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/aws-sdk')
-rw-r--r--dev-ruby/aws-sdk/ChangeLog8
-rw-r--r--dev-ruby/aws-sdk/aws-sdk-1.5.8.ebuild (renamed from dev-ruby/aws-sdk/aws-sdk-1.5.7.ebuild)3
-rw-r--r--dev-ruby/aws-sdk/files/aws-sdk-1.5.7-specs.patch31
3 files changed, 8 insertions, 34 deletions
diff --git a/dev-ruby/aws-sdk/ChangeLog b/dev-ruby/aws-sdk/ChangeLog
index 5ef621a35fe9..84d3a374244a 100644
--- a/dev-ruby/aws-sdk/ChangeLog
+++ b/dev-ruby/aws-sdk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/aws-sdk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/ChangeLog,v 1.5 2012/07/13 10:55:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/ChangeLog,v 1.6 2012/07/27 01:29:46 flameeyes Exp $
+
+*aws-sdk-1.5.8 (27 Jul 2012)
+
+ 27 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> +aws-sdk-1.5.8.ebuild,
+ -aws-sdk-1.5.7.ebuild, -files/aws-sdk-1.5.7-specs.patch:
+ Version bump (my patch has been merged).
*aws-sdk-1.5.7 (13 Jul 2012)
diff --git a/dev-ruby/aws-sdk/aws-sdk-1.5.7.ebuild b/dev-ruby/aws-sdk/aws-sdk-1.5.8.ebuild
index 34f159d02a6e..af2d6df0459d 100644
--- a/dev-ruby/aws-sdk/aws-sdk-1.5.7.ebuild
+++ b/dev-ruby/aws-sdk/aws-sdk-1.5.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/aws-sdk-1.5.7.ebuild,v 1.1 2012/07/13 10:55:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/aws-sdk-1.5.8.ebuild,v 1.1 2012/07/27 01:29:46 flameeyes Exp $
EAPI=4
@@ -38,7 +38,6 @@ ruby_add_rdepend "virtual/ruby-ssl
all_ruby_prepare() {
epatch "${FILESDIR}"/${PN}-1.5.3-disabletest.patch
- epatch "${FILESDIR}"/${P}-specs.patch
}
all_ruby_compile() {
diff --git a/dev-ruby/aws-sdk/files/aws-sdk-1.5.7-specs.patch b/dev-ruby/aws-sdk/files/aws-sdk-1.5.7-specs.patch
deleted file mode 100644
index b8954a0cc465..000000000000
--- a/dev-ruby/aws-sdk/files/aws-sdk-1.5.7-specs.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/spec/aws/cloud_watch/alarm_history_item_collection_spec.rb b/spec/aws/cloud_watch/alarm_history_item_collection_spec.rb
-index 912d057..5b65426 100644
---- a/spec/aws/cloud_watch/alarm_history_item_collection_spec.rb
-+++ b/spec/aws/cloud_watch/alarm_history_item_collection_spec.rb
-@@ -38,7 +38,7 @@ module AWS
- it 'returns a collection that applies the filter when enumerating' do
- client.should_receive(:describe_alarm_history).with(
- :abc => 'xyz',
-- :mno => 'hjk',
-+ :mno => 'hjk'
- ).and_return(client.stub_for(:describe_alarm_history))
- items.filter('abc', 'xyz').filter('mno', 'hjk').to_a
- end
-diff --git a/spec/spec_helper.rb b/spec/spec_helper.rb
-index c55235c..fea5527 100644
---- a/spec/spec_helper.rb
-+++ b/spec/spec_helper.rb
-@@ -14,12 +14,11 @@
- $: << File.join(File.dirname(File.dirname(__FILE__)), "lib")
-
- require 'rspec'
-+require 'aws'
-
- # require all _examples.rb files in spec/shared/
- Dir.glob("#{File.dirname(__FILE__)}/shared/**/*_examples.rb").each do |file|
- require file
- end
-
--require 'aws'
--
- AWS.eager_autoload!