summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-01-28 07:17:36 +0000
committerHans de Graaff <graaff@gentoo.org>2013-01-28 07:17:36 +0000
commit2881ddf864e70c8c47de33e14f09a6331fd700b0 (patch)
tree8eab03ff892fe33bcb7c79eed18d1db60d062f1d /dev-ruby/amatch
parentCleanup. (diff)
downloadgentoo-2-2881ddf864e70c8c47de33e14f09a6331fd700b0.tar.gz
gentoo-2-2881ddf864e70c8c47de33e14f09a6331fd700b0.tar.bz2
gentoo-2-2881ddf864e70c8c47de33e14f09a6331fd700b0.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/amatch')
-rw-r--r--dev-ruby/amatch/ChangeLog7
-rw-r--r--dev-ruby/amatch/amatch-0.2.11.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/amatch/ChangeLog b/dev-ruby/amatch/ChangeLog
index 563c9e206681..b13ed1b9b6b7 100644
--- a/dev-ruby/amatch/ChangeLog
+++ b/dev-ruby/amatch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/amatch
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amatch/ChangeLog,v 1.34 2013/01/28 07:15:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amatch/ChangeLog,v 1.35 2013/01/28 07:17:36 graaff Exp $
+
+*amatch-0.2.11 (28 Jan 2013)
+
+ 28 Jan 2013; Hans de Graaff <graaff@gentoo.org> +amatch-0.2.11.ebuild:
+ Version bump.
28 Jan 2013; Hans de Graaff <graaff@gentoo.org> -amatch-0.2.5.ebuild:
Cleanup.
diff --git a/dev-ruby/amatch/amatch-0.2.11.ebuild b/dev-ruby/amatch/amatch-0.2.11.ebuild
new file mode 100644
index 000000000000..3d87c4ec2fa0
--- /dev/null
+++ b/dev-ruby/amatch/amatch-0.2.11.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amatch/amatch-0.2.11.ebuild,v 1.1 2013/01/28 07:17:36 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Approximate Matching Extension for Ruby"
+HOMEPAGE="http://flori.github.com/amatch/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/tins-0.3"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext
+ cp ext/amatch_ext$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb tests/* || die
+}