summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-03 06:19:53 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-03 06:19:53 +0000
commit684db680450cffe47926bd3f3c36e55a8850c96a (patch)
treefdcae1d72ead50675120795a5530409fa43af148 /dev-ruby/actionview
parentVersion bump to Rails 4.1.4 for security bug 516084. (diff)
downloadgentoo-2-684db680450cffe47926bd3f3c36e55a8850c96a.tar.gz
gentoo-2-684db680450cffe47926bd3f3c36e55a8850c96a.tar.bz2
gentoo-2-684db680450cffe47926bd3f3c36e55a8850c96a.zip
Version bump to Rails 4.1.4 for security bug 516084.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionview')
-rw-r--r--dev-ruby/actionview/ChangeLog7
-rw-r--r--dev-ruby/actionview/actionview-4.1.4.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/actionview/ChangeLog b/dev-ruby/actionview/ChangeLog
index 3d562e9cdb02..163c5c0096b0 100644
--- a/dev-ruby/actionview/ChangeLog
+++ b/dev-ruby/actionview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionview
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/ChangeLog,v 1.4 2014/06/26 20:06:42 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/ChangeLog,v 1.5 2014/07/03 06:19:53 graaff Exp $
+
+*actionview-4.1.4 (03 Jul 2014)
+
+ 03 Jul 2014; Hans de Graaff <graaff@gentoo.org> +actionview-4.1.4.ebuild:
+ Version bump to Rails 4.1.4 for security bug 516084.
*actionview-4.1.2 (26 Jun 2014)
diff --git a/dev-ruby/actionview/actionview-4.1.4.ebuild b/dev-ruby/actionview/actionview-4.1.4.ebuild
new file mode 100644
index 000000000000..248fd5aecc10
--- /dev/null
+++ b/dev-ruby/actionview/actionview-4.1.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/actionview-4.1.4.ebuild,v 1.1 2014/07/03 06:19:53 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Simple, battle-tested conventions and helpers for building web pages"
+HOMEPAGE="https://github.com/rails/rails/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1 =dev-ruby/builder-3*
+ >=dev-ruby/erubis-2.7.0
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activemodel-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\)/ s:^:#:" ../Gemfile || die
+
+}