summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-06-16 21:59:06 +0000
committerHans de Graaff <graaff@gentoo.org>2015-06-16 21:59:06 +0000
commita8d2363d1a298657da36aa68e2ae5c3f31c5afc1 (patch)
treeaaa568bd4614b70c10867ef5184ded25811e49d2 /dev-ruby/actionmailer
parentVersion bump. (diff)
downloadgentoo-2-a8d2363d1a298657da36aa68e2ae5c3f31c5afc1.tar.gz
gentoo-2-a8d2363d1a298657da36aa68e2ae5c3f31c5afc1.tar.bz2
gentoo-2-a8d2363d1a298657da36aa68e2ae5c3f31c5afc1.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.2.2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 342bb33dd931..b9495cd27a98 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.288 2015/06/16 21:35:53 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.289 2015/06/16 21:59:06 graaff Exp $
+
+*actionmailer-4.2.2 (16 Jun 2015)
+
+ 16 Jun 2015; Hans de Graaff <graaff@gentoo.org> +actionmailer-4.2.2.ebuild:
+ Version bump.
*actionmailer-4.1.11 (16 Jun 2015)
diff --git a/dev-ruby/actionmailer/actionmailer-4.2.2.ebuild b/dev-ruby/actionmailer/actionmailer-4.2.2.ebuild
new file mode 100644
index 000000000000..0ba0c4a0b9b4
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.2.2.ebuild,v 1.1 2015/06/16 21:59:06 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/actionview-${PV}
+ ~dev-ruby/activejob-${PV}
+ >=dev-ruby/mail-2.5.4:2.5
+ >=dev-ruby/rails-dom-testing-1.0.5:1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:0.14
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+
+ # Avoid a test failing only on attachment ordering, since this is a
+ # security release.
+ sed -i -e '/adding inline attachments while rendering mail works/askip "gentoo: fails on ordering"' test/base_test.rb || die
+}