summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-06-26 08:33:09 +0000
committerHans de Graaff <graaff@gentoo.org>2015-06-26 08:33:09 +0000
commit58b3b5cc9ead086413ab90aff7adc40eec5d7d8b (patch)
tree191fa3f068d53daebecf2d0f5987a5e2944f309c /dev-ruby/actionmailer
parentVersion bump. (diff)
downloadgentoo-2-58b3b5cc9ead086413ab90aff7adc40eec5d7d8b.tar.gz
gentoo-2-58b3b5cc9ead086413ab90aff7adc40eec5d7d8b.tar.bz2
gentoo-2-58b3b5cc9ead086413ab90aff7adc40eec5d7d8b.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.2.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 4c6b411b860e..5d3eecf82290 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.290 2015/06/26 06:27:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.291 2015/06/26 08:33:09 graaff Exp $
+
+*actionmailer-4.2.3 (26 Jun 2015)
+
+ 26 Jun 2015; Hans de Graaff <graaff@gentoo.org> +actionmailer-4.2.3.ebuild:
+ Version bump.
*actionmailer-4.1.12 (26 Jun 2015)
diff --git a/dev-ruby/actionmailer/actionmailer-4.2.3.ebuild b/dev-ruby/actionmailer/actionmailer-4.2.3.ebuild
new file mode 100644
index 000000000000..128e9e5b5141
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.2.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.2.3.ebuild,v 1.1 2015/06/26 08:33:09 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/actionview-${PV}
+ ~dev-ruby/activejob-${PV}
+ >=dev-ruby/mail-2.5.4:2.5
+ >=dev-ruby/rails-dom-testing-1.0.5:1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/mocha:0.14
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Avoid a test failing only on attachment ordering, since this is a
+ # security release.
+ sed -i -e '/adding inline attachments while rendering mail works/askip "gentoo: fails on ordering"' test/base_test.rb || die
+}