summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-01-16 18:22:05 +0000
committerHans de Graaff <graaff@gentoo.org>2010-01-16 18:22:05 +0000
commit5198a27a096ffa5a10df672313e205f578e3a06b (patch)
tree2d368b8a62b82b6320676ed279897060236bba9f /dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild
parentkeyworded ~arch for x86, bug 297734 (diff)
downloadgentoo-2-5198a27a096ffa5a10df672313e205f578e3a06b.tar.gz
gentoo-2-5198a27a096ffa5a10df672313e205f578e3a06b.tar.bz2
gentoo-2-5198a27a096ffa5a10df672313e205f578e3a06b.zip
Version bump. Convert to ruby-fakegem.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild')
-rw-r--r--dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild b/dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild
new file mode 100644
index 000000000000..9901530b4966
--- /dev/null
+++ b/dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild,v 1.1 2010/01/16 18:22:05 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_DOCDIR="docs/html"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README"
+
+inherit ruby-fakegem
+
+MY_P="io-reactor-${PV}"
+
+DESCRIPTION="IO Reactor for event-driven multiplexed IO in a single thread"
+HOMEPAGE="http://www.deveiate.org/projects/IO-Reactor/"
+SRC_URI="mirror://rubygems/${MY_P}.gem"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86-fbsd ~x86"
+IUSE="examples"
+
+ruby_add_bdepend test dev-ruby/rspec
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}