summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-04-19 18:49:57 +0000
committerMichael Palimaka <kensington@gentoo.org>2015-04-19 18:49:57 +0000
commit9bef6b10eef1728c7c500a93192d2c9922f1f688 (patch)
tree0c74f88da29b51d2d6e3d297def6e5f54af5f61d /dev-qt/qtgui
parentCreate stable candidate. (diff)
downloadgentoo-2-9bef6b10eef1728c7c500a93192d2c9922f1f688.tar.gz
gentoo-2-9bef6b10eef1728c7c500a93192d2c9922f1f688.tar.bz2
gentoo-2-9bef6b10eef1728c7c500a93192d2c9922f1f688.zip
Add gtkstyle USE flag by Harvey Mittens <teknocratdefunct@riseup.net> and Davide Pesavento <pesa@gentoo.org> wrt bug #526866.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'dev-qt/qtgui')
-rw-r--r--dev-qt/qtgui/ChangeLog6
-rw-r--r--dev-qt/qtgui/qtgui-5.4.1-r1.ebuild19
2 files changed, 19 insertions, 6 deletions
diff --git a/dev-qt/qtgui/ChangeLog b/dev-qt/qtgui/ChangeLog
index dbec5f433778..529a9c40aacb 100644
--- a/dev-qt/qtgui/ChangeLog
+++ b/dev-qt/qtgui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-qt/qtgui
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtgui/ChangeLog,v 1.76 2015/04/15 03:47:56 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtgui/ChangeLog,v 1.77 2015/04/19 18:49:57 kensington Exp $
+
+ 19 Apr 2015; Michael Palimaka <kensington@gentoo.org> qtgui-5.4.1-r1.ebuild:
+ Add gtkstyle USE flag by Harvey Mittens <teknocratdefunct@riseup.net> and
+ Davide Pesavento <pesa@gentoo.org> wrt bug #526866.
15 Apr 2015; Yixun Lan <dlan@gentoo.org> qtgui-4.8.6-r2.ebuild:
keyword arm64, tested on cortex-a53 hardware
diff --git a/dev-qt/qtgui/qtgui-5.4.1-r1.ebuild b/dev-qt/qtgui/qtgui-5.4.1-r1.ebuild
index c9ae802db828..1a4f3e42209c 100644
--- a/dev-qt/qtgui/qtgui-5.4.1-r1.ebuild
+++ b/dev-qt/qtgui/qtgui-5.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtgui/qtgui-5.4.1-r1.ebuild,v 1.1 2015/03/17 14:24:12 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtgui/qtgui-5.4.1-r1.ebuild,v 1.2 2015/04/19 18:49:57 kensington Exp $
EAPI=5
@@ -18,7 +18,7 @@ fi
# TODO: directfb, linuxfb, offscreen (auto-depends on X11)
-IUSE="accessibility egl eglfs evdev +gif gles2 +harfbuzz ibus jpeg kms +opengl +png udev +xcb"
+IUSE="accessibility egl eglfs evdev +gif gles2 gtkstyle +harfbuzz ibus jpeg kms +opengl +png udev +xcb"
REQUIRED_USE="
egl? ( evdev opengl )
eglfs? ( egl )
@@ -34,6 +34,11 @@ RDEPEND="
sys-libs/zlib
egl? ( media-libs/mesa[egl] )
evdev? ( sys-libs/mtdev )
+ gtkstyle? (
+ x11-libs/gtk+:2
+ x11-libs/pango
+ !!x11-libs/cairo[qt4]
+ )
gles2? ( media-libs/mesa[gles2] )
harfbuzz? ( >=media-libs/harfbuzz-0.9.32:= )
ibus? ( ~dev-qt/qtdbus-${PV}[debug=] )
@@ -92,6 +97,8 @@ QT5_GENTOO_CONFIG=(
!gif:no-gif:
gles2::OPENGL_ES
gles2:opengles2:OPENGL_ES_2
+ gtkstyle:gtkstyle:
+ gtkstyle:gtk2:STYLE_GTK
!:no-gui:
harfbuzz:system-harfbuzz:HARFBUZZ
!harfbuzz:no-harfbuzz:
@@ -114,9 +121,10 @@ QT5_GENTOO_CONFIG=(
)
pkg_setup() {
- use opengl && QT5_TARGET_SUBDIRS+=(src/openglextensions)
- use ibus && QT5_TARGET_SUBDIRS+=(src/plugins/platforminputcontexts/ibus)
- use xcb && QT5_TARGET_SUBDIRS+=(src/plugins/platforminputcontexts/compose)
+ use opengl && QT5_TARGET_SUBDIRS+=(src/openglextensions)
+ use gtkstyle && QT5_TARGET_SUBDIRS+=(src/plugins/platformthemes/gtk2)
+ use ibus && QT5_TARGET_SUBDIRS+=(src/plugins/platforminputcontexts/ibus)
+ use xcb && QT5_TARGET_SUBDIRS+=(src/plugins/platforminputcontexts/compose)
# egl_x11 is activated when both egl and xcb are enabled
use egl && QT5_GENTOO_CONFIG+=(xcb:egl_x11) || QT5_GENTOO_CONFIG+=(egl:egl_x11)
@@ -141,6 +149,7 @@ src_configure() {
-system-freetype
$(use gif || echo -no-gif)
${gl}
+ $(qt_use gtkstyle)
$(qt_use harfbuzz harfbuzz system)
$(qt_use jpeg libjpeg system)
$(qt_use kms)