summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-26 18:24:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-26 18:24:41 +0000
commitf319c0d01c8f7c14dd6a1acc373e772925b35c88 (patch)
tree7772bfaf6833ab69312354659968f091ae84f176 /dev-python
parentstable amd64, bug 315495 (diff)
downloadgentoo-2-f319c0d01c8f7c14dd6a1acc373e772925b35c88.tar.gz
gentoo-2-f319c0d01c8f7c14dd6a1acc373e772925b35c88.tar.bz2
gentoo-2-f319c0d01c8f7c14dd6a1acc373e772925b35c88.zip
Simplify src_test().
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx/sphinx-0.6.5.ebuild16
-rw-r--r--dev-python/sphinx/sphinx-0.6.6.ebuild16
-rw-r--r--dev-python/sphinx/sphinx-1.0_beta1.ebuild16
3 files changed, 15 insertions, 33 deletions
diff --git a/dev-python/sphinx/sphinx-0.6.5.ebuild b/dev-python/sphinx/sphinx-0.6.5.ebuild
index 34c09e9f8526..c0e0253752db 100644
--- a/dev-python/sphinx/sphinx-0.6.5.ebuild
+++ b/dev-python/sphinx/sphinx-0.6.5.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.5.ebuild,v 1.9 2010/05/21 20:56:18 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.5.ebuild,v 1.10 2010/05/26 18:24:41 arfrever Exp $
-EAPI="2"
+EAPI="3"
SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -36,17 +37,11 @@ src_compile() {
if use doc; then
cd doc
+ einfo "Generation of documentation"
PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
fi
}
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
src_install() {
distutils_src_install
@@ -60,8 +55,7 @@ pkg_postinst() {
# Generating the Grammar pickle to avoid on the fly generation causing sandbox violations (bug #266015)
generation_of_grammar_pickle() {
- "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" \
- || die "Generation of grammar pickle failed"
+ "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" || die "Generation of grammar pickle failed"
}
python_execute_function --action-message 'Generation of Grammar pickle with Python ${PYTHON_ABI}...' generation_of_grammar_pickle
}
diff --git a/dev-python/sphinx/sphinx-0.6.6.ebuild b/dev-python/sphinx/sphinx-0.6.6.ebuild
index 6ca8b5609864..e85ac26fa099 100644
--- a/dev-python/sphinx/sphinx-0.6.6.ebuild
+++ b/dev-python/sphinx/sphinx-0.6.6.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.6.ebuild,v 1.1 2010/05/25 10:38:38 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.6.ebuild,v 1.2 2010/05/26 18:24:41 arfrever Exp $
-EAPI="2"
+EAPI="3"
SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -36,17 +37,11 @@ src_compile() {
if use doc; then
cd doc
+ einfo "Generation of documentation"
PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
fi
}
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
src_install() {
distutils_src_install
@@ -60,8 +55,7 @@ pkg_postinst() {
# Generating the Grammar pickle to avoid on the fly generation causing sandbox violations (bug #266015)
generation_of_grammar_pickle() {
- "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" \
- || die "Generation of grammar pickle failed"
+ "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" || die "Generation of grammar pickle failed"
}
python_execute_function --action-message 'Generation of Grammar pickle with Python ${PYTHON_ABI}...' generation_of_grammar_pickle
}
diff --git a/dev-python/sphinx/sphinx-1.0_beta1.ebuild b/dev-python/sphinx/sphinx-1.0_beta1.ebuild
index 81f44c5bc7ee..0136a56f7f6a 100644
--- a/dev-python/sphinx/sphinx-1.0_beta1.ebuild
+++ b/dev-python/sphinx/sphinx-1.0_beta1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.0_beta1.ebuild,v 1.1 2010/05/25 10:53:47 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.0_beta1.ebuild,v 1.2 2010/05/26 18:24:41 arfrever Exp $
-EAPI="2"
+EAPI="3"
SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -36,17 +37,11 @@ src_compile() {
if use doc; then
cd doc
+ einfo "Generation of documentation"
PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
fi
}
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
src_install() {
distutils_src_install
@@ -60,8 +55,7 @@ pkg_postinst() {
# Generating the Grammar pickle to avoid on the fly generation causing sandbox violations (bug #266015)
generation_of_grammar_pickle() {
- "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" \
- || die "Generation of grammar pickle failed"
+ "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" || die "Generation of grammar pickle failed"
}
python_execute_function --action-message 'Generation of Grammar pickle with Python ${PYTHON_ABI}...' generation_of_grammar_pickle
}