summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2011-03-20 19:08:13 +0000
committerTomás Touceda <chiiph@gentoo.org>2011-03-20 19:08:13 +0000
commite1510645ba5e874849ffc906e182d90b63ed3e89 (patch)
tree82be6365c43fe7da25a462264331fb454df936a6 /dev-python
parentFix building on ppc (bug #359515 by Brent Baude). (diff)
downloadgentoo-2-e1510645ba5e874849ffc906e182d90b63ed3e89.tar.gz
gentoo-2-e1510645ba5e874849ffc906e182d90b63ed3e89.tar.bz2
gentoo-2-e1510645ba5e874849ffc906e182d90b63ed3e89.zip
Version bump to 0.10.0
(Portage version: 2.2.0_alpha26/cvs/Linux i686)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apiextractor/ChangeLog9
-rw-r--r--dev-python/apiextractor/apiextractor-0.10.0.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-python/apiextractor/ChangeLog b/dev-python/apiextractor/ChangeLog
index c0a83d6afa7b..2bc80d01783e 100644
--- a/dev-python/apiextractor/ChangeLog
+++ b/dev-python/apiextractor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/apiextractor
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/ChangeLog,v 1.9 2010/11/25 01:16:25 chiiph Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/ChangeLog,v 1.10 2011/03/20 19:08:13 chiiph Exp $
+
+*apiextractor-0.10.0 (20 Mar 2011)
+
+ 20 Mar 2011; Tomas Touceda <chiiph@gentoo.org> +apiextractor-0.10.0.ebuild:
+ Version bump to 0.10.0
21 Nov 2010; Tomas Touceda <chiiph@gentoo.org> -apiextractor-0.3.2.ebuild,
-apiextractor-0.3.3.ebuild, -apiextractor-0.6.0.ebuild,
diff --git a/dev-python/apiextractor/apiextractor-0.10.0.ebuild b/dev-python/apiextractor/apiextractor-0.10.0.ebuild
new file mode 100644
index 000000000000..0556c6d0c2be
--- /dev/null
+++ b/dev-python/apiextractor/apiextractor-0.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.10.0.ebuild,v 1.1 2011/03/20 19:08:13 chiiph Exp $
+
+EAPI="2"
+
+inherit cmake-utils virtualx
+
+DESCRIPTION="Library used to create an internal representation of an API in order to create Python bindings"
+HOMEPAGE="http://www.pyside.org/"
+SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+RDEPEND=">=dev-libs/boost-1.41.0[python]
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=x11-libs/qt-core-4.5.0
+ >=x11-libs/qt-xmlpatterns-4.5.0"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( >=x11-libs/qt-test-4.5.0 )"
+TEST_VERBOSE="1"
+
+src_configure() {
+ mycmakeargs="$(cmake-utils_use_build test TESTS)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS ChangeLog || die "dodoc failed"
+}