summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2006-10-04 19:43:52 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2006-10-04 19:43:52 +0000
commitcec69d4685e5db2acb5121df7b8d472899b1c848 (patch)
tree85f58048815518871181e9e30a4c8c937db1d648 /dev-python
parentclean IUSE (diff)
downloadgentoo-2-cec69d4685e5db2acb5121df7b8d472899b1c848.tar.gz
gentoo-2-cec69d4685e5db2acb5121df7b8d472899b1c848.tar.bz2
gentoo-2-cec69d4685e5db2acb5121df7b8d472899b1c848.zip
Version bump.
(Portage version: 2.1.2_pre1-r1)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/urwid/ChangeLog7
-rw-r--r--dev-python/urwid/files/digest-urwid-0.9.7.13
-rw-r--r--dev-python/urwid/urwid-0.9.7.1.ebuild37
3 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index 447e67d2aafb..8c75712165b5 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/urwid
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.16 2006/08/23 18:57:43 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.17 2006/10/04 19:43:51 lucass Exp $
+
+*urwid-0.9.7.1 (04 Oct 2006)
+
+ 04 Oct 2006; Lukasz Strzygowski <lucass@gentoo.org> +urwid-0.9.7.1.ebuild:
+ Version bump.
*urwid-0.9.6 (23 Aug 2006)
diff --git a/dev-python/urwid/files/digest-urwid-0.9.7.1 b/dev-python/urwid/files/digest-urwid-0.9.7.1
new file mode 100644
index 000000000000..c0c805d61e2e
--- /dev/null
+++ b/dev-python/urwid/files/digest-urwid-0.9.7.1
@@ -0,0 +1,3 @@
+MD5 fa551f5c275a47fc5a627cc1fce17c90 urwid-0.9.7.1.tar.gz 153698
+RMD160 e8e770ce4cbb5bacfc6ab3b2807321080aa81786 urwid-0.9.7.1.tar.gz 153698
+SHA256 394b6389faa75ace00adb6111377c49148d951bf40571c8e489510f10c743faf urwid-0.9.7.1.tar.gz 153698
diff --git a/dev-python/urwid/urwid-0.9.7.1.ebuild b/dev-python/urwid/urwid-0.9.7.1.ebuild
new file mode 100644
index 000000000000..beec79ef652d
--- /dev/null
+++ b/dev-python/urwid/urwid-0.9.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-0.9.7.1.ebuild,v 1.1 2006/10/04 19:43:51 lucass Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python."
+HOMEPAGE="http://excess.org/urwid/"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="examples"
+DEPEND="virtual/python"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.9.6-nosetuptools.diff"
+}
+
+src_test() {
+ ${python} test_urwid.py || die "unit tests failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml tutorial.html reference.html
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins bigtext.py browse.py calc.py dialog.py edit.py
+ doins fib.py graph.py input_test.py tour.py
+ fi
+}