summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-03 22:18:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-03 22:18:27 +0000
commita78f19217a18e751b482ed2d5fc6f00bfc5c0b6b (patch)
tree0a4539d765ab88cf152c1f9c4c6d94e1a5390f37 /dev-python
parentstable x86, security bug 287490 (diff)
downloadgentoo-2-a78f19217a18e751b482ed2d5fc6f00bfc5c0b6b.tar.gz
gentoo-2-a78f19217a18e751b482ed2d5fc6f00bfc5c0b6b.tar.bz2
gentoo-2-a78f19217a18e751b482ed2d5fc6f00bfc5c0b6b.zip
Version bump.
(Portage version: 14484-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ipy/ChangeLog8
-rw-r--r--dev-python/ipy/ipy-0.53.ebuild31
-rw-r--r--dev-python/ipy/ipy-0.64.ebuild41
3 files changed, 48 insertions, 32 deletions
diff --git a/dev-python/ipy/ChangeLog b/dev-python/ipy/ChangeLog
index 63156c3b0792..32e5842e1bdb 100644
--- a/dev-python/ipy/ChangeLog
+++ b/dev-python/ipy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ipy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ChangeLog,v 1.14 2009/09/07 21:18:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ChangeLog,v 1.15 2009/10/03 22:18:27 arfrever Exp $
+
+*ipy-0.64 (04 Oct 2009)
+
+ 04 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -ipy-0.53.ebuild, +ipy-0.64.ebuild:
+ Version bump.
07 Sep 2009; Markus Meier <maekke@gentoo.org> ipy-0.56.ebuild:
amd64/x86 stable, bug #283080
diff --git a/dev-python/ipy/ipy-0.53.ebuild b/dev-python/ipy/ipy-0.53.ebuild
deleted file mode 100644
index 82c21c02e08f..000000000000
--- a/dev-python/ipy/ipy-0.53.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.53.ebuild,v 1.5 2007/12/30 09:32:30 drac Exp $
-
-inherit eutils distutils
-
-MY_P="${P/ip/IP}"
-
-DESCRIPTION="A python Module for handling IP-Addresses and Networks"
-SRC_URI="http://cheeseshop.python.org/packages/source/I/IPy/${MY_P}.tar.gz"
-HOMEPAGE="http://software.inl.fr/trac/trac.cgi/wiki/IPy"
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
-IUSE="examples"
-
-S="${WORKDIR}/${MY_P}"
-
-src_test() {
- "${python}" test/test_IPy.py || die "src_test failed"
-}
-
-src_install() {
- DOCS="AUTHORS"
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r example
- fi
-}
diff --git a/dev-python/ipy/ipy-0.64.ebuild b/dev-python/ipy/ipy-0.64.ebuild
new file mode 100644
index 000000000000..47979f7936e0
--- /dev/null
+++ b/dev-python/ipy/ipy-0.64.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.64.ebuild,v 1.1 2009/10/03 22:18:27 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="IPy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A python Module for handling IP-Addresses and Networks"
+HOMEPAGE="http://software.inl.fr/trac/trac.cgi/wiki/IPy http://pypi.python.org/pypi/IPy"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_IPy.py
+ }
+ python_execute_function testing
+}
+
+pkg_postinst() {
+ python_mod_optimize IPy.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}