summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-01-23 04:55:09 +0000
committerIan Delaney <idella4@gentoo.org>2014-01-23 04:55:09 +0000
commit986913f19071d74d90e204b64b69a2cc73951809 (patch)
tree9004cbb0791ff1474cccc6429d46c9d6f5c4d7bc /dev-python
parentVersion bump (bug #498918). (diff)
downloadgentoo-2-986913f19071d74d90e204b64b69a2cc73951809.tar.gz
gentoo-2-986913f19071d74d90e204b64b69a2cc73951809.tar.bz2
gentoo-2-986913f19071d74d90e204b64b69a2cc73951809.zip
bump; drop py2.6, add py3 support, add pytest to tun tests, unrestrict test phase, re-write of test phase
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-sqlparse/ChangeLog9
-rw-r--r--dev-python/python-sqlparse/python-sqlparse-0.1.10.ebuild33
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/python-sqlparse/ChangeLog b/dev-python/python-sqlparse/ChangeLog
index 5a51df6efdbb..c35ca0404fec 100644
--- a/dev-python/python-sqlparse/ChangeLog
+++ b/dev-python/python-sqlparse/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-sqlparse
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/ChangeLog,v 1.20 2014/01/06 08:22:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/ChangeLog,v 1.21 2014/01/23 04:55:09 idella4 Exp $
+
+*python-sqlparse-0.1.10 (23 Jan 2014)
+
+ 23 Jan 2014; Ian Delaney <idella4@gentoo.org> +python-sqlparse-0.1.10.ebuild,
+ python-sqlparse-0.1.5-r1.ebuild:
+ bump; drop py2.6, add py3 support, add pytest to tun tests, unrestrict test
+ phase, re-write of test phase
06 Jan 2014; Justin Lecher <jlec@gentoo.org> -python-sqlparse-0.1.3.ebuild,
-python-sqlparse-0.1.4.ebuild, -python-sqlparse-0.1.5.ebuild:
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.1.10.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.1.10.ebuild
new file mode 100644
index 000000000000..f0b6bf673d61
--- /dev/null
+++ b/dev-python/python-sqlparse/python-sqlparse-0.1.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/python-sqlparse-0.1.10.ebuild,v 1.1 2014/01/23 04:55:09 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="http://code.google.com/p/python-sqlparse/ https://github.com/andialbrecht/sqlparse"
+SRC_URI="https://github.com/andialbrecht/sqlparse/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD-2"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+DISTUTILS_IN_SOURCE_BUILD=1 # Required for running tests
+
+S="${WORKDIR}"/${P#python-}
+
+python_test() {
+ if python_is_python3; then
+ 2to3 -w --no-diffs -n tests/ sqlparse/
+ py.test ./tests || die "testsuite failed ${EPYTHON}"
+ else
+ py.test tests || die "testsuite failed under ${EPYTHON}"
+ fi
+}