summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-06-14 08:41:22 +0000
committerIan Delaney <idella4@gentoo.org>2015-06-14 08:41:22 +0000
commit8e701797dbd81542c617a6317a5994a684f8ede7 (patch)
tree1b7bc764a3e01e90666d638dbe8691a3273c8f62 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-8e701797dbd81542c617a6317a5994a684f8ede7.tar.gz
gentoo-2-8e701797dbd81542c617a6317a5994a684f8ede7.tar.bz2
gentoo-2-8e701797dbd81542c617a6317a5994a684f8ede7.zip
bump reset test phase as it was intended
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fixtures/ChangeLog9
-rw-r--r--dev-python/fixtures/fixtures-0.3.12-r1.ebuild30
-rw-r--r--dev-python/fixtures/fixtures-0.3.14-r1.ebuild31
-rw-r--r--dev-python/fixtures/fixtures-1.2.0.ebuild (renamed from dev-python/fixtures/fixtures-0.3.14.ebuild)16
4 files changed, 15 insertions, 71 deletions
diff --git a/dev-python/fixtures/ChangeLog b/dev-python/fixtures/ChangeLog
index ce11023e63a0..21e1894f98ef 100644
--- a/dev-python/fixtures/ChangeLog
+++ b/dev-python/fixtures/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/fixtures
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/ChangeLog,v 1.29 2015/06/09 15:16:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/ChangeLog,v 1.30 2015/06/14 08:41:22 idella4 Exp $
+
+*fixtures-1.2.0 (14 Jun 2015)
+
+ 14 Jun 2015; Ian Delaney <idella4@gentoo.org> +fixtures-1.2.0.ebuild,
+ -fixtures-0.3.12-r1.ebuild, -fixtures-0.3.14-r1.ebuild,
+ -fixtures-0.3.14.ebuild:
+ bump reset test phase as it was intended
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/dev-python/fixtures/fixtures-0.3.12-r1.ebuild b/dev-python/fixtures/fixtures-0.3.12-r1.ebuild
deleted file mode 100644
index 64ead49ed631..000000000000
--- a/dev-python/fixtures/fixtures-0.3.12-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.12-r1.ebuild,v 1.6 2015/04/08 08:04:54 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
-HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 BSD )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-
-# nose not listed but provides coverage output of tests
-# run of test files by python lacks any output except on fail
-DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=">=dev-python/testtools-0.9.22"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_test() {
- pushd "${BUILD_DIR}"/ > /dev/null
- ln -sf ../README .
- nosetests lib/${PN}/tests/{test_callmany.py,test_fixture.py,test_testcase.py} \
- || die "Tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/fixtures/fixtures-0.3.14-r1.ebuild b/dev-python/fixtures/fixtures-0.3.14-r1.ebuild
deleted file mode 100644
index 2d943f487e6d..000000000000
--- a/dev-python/fixtures/fixtures-0.3.14-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.14-r1.ebuild,v 1.11 2015/04/08 08:04:54 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
-HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 BSD )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# nose not listed but provides coverage output of tests
-# run of test files by python lacks any output except on fail
-DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]
- dev-python/extras[${PYTHON_USEDEP}] )"
-RDEPEND=">=dev-python/testtools-0.9.22"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_test() {
- pushd "${BUILD_DIR}"/ > /dev/null
- ln -sf ../README .
- nosetests lib/${PN}/tests/test_*.py || die "Tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/fixtures/fixtures-0.3.14.ebuild b/dev-python/fixtures/fixtures-1.2.0.ebuild
index d94a96c55f3a..07f9c903f187 100644
--- a/dev-python/fixtures/fixtures-0.3.14.ebuild
+++ b/dev-python/fixtures/fixtures-1.2.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.14.ebuild,v 1.4 2015/04/08 08:04:54 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-1.2.0.ebuild,v 1.1 2015/06/14 08:41:22 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -13,18 +13,16 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="|| ( Apache-2.0 BSD )"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
# nose not listed but provides coverage output of tests
# run of test files by python lacks any output except on fail
-DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+DEPEND="test? ( >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}] )"
RDEPEND=">=dev-python/testtools-0.9.22"
-DISTUTILS_IN_SOURCE_BUILD=1
+#DISTUTILS_IN_SOURCE_BUILD=1
python_test() {
- pushd "${BUILD_DIR}"/ > /dev/null
- ln -sf ../README .
- nosetests lib/${PN}/tests/{test_callmany.py,test_fixture.py,test_testcase.py} \
- || die "Tests failed under ${EPYTHON}"
+ emake check
}