summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-02-10 05:31:47 +0000
committerTim Harder <radhermit@gentoo.org>2013-02-10 05:31:47 +0000
commit7ad1abec2cd2e03786d3780a97a72689eea023ee (patch)
tree27328858dc85549e740c889b7974c8b86eb4af9f /dev-python
parentReinstated patch to fix locale/utf8 in test, py3 specific, cited and tested i... (diff)
downloadgentoo-2-7ad1abec2cd2e03786d3780a97a72689eea023ee.tar.gz
gentoo-2-7ad1abec2cd2e03786d3780a97a72689eea023ee.tar.bz2
gentoo-2-7ad1abec2cd2e03786d3780a97a72689eea023ee.zip
Version bump.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyGithub/ChangeLog7
-rw-r--r--dev-python/PyGithub/PyGithub-1.11.1.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/PyGithub/ChangeLog b/dev-python/PyGithub/ChangeLog
index fae4f43198a0..d5fbb71128cd 100644
--- a/dev-python/PyGithub/ChangeLog
+++ b/dev-python/PyGithub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyGithub
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyGithub/ChangeLog,v 1.3 2013/01/20 20:31:47 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyGithub/ChangeLog,v 1.4 2013/02/10 05:31:47 radhermit Exp $
+
+*PyGithub-1.11.1 (10 Feb 2013)
+
+ 10 Feb 2013; Tim Harder <radhermit@gentoo.org> +PyGithub-1.11.1.ebuild:
+ Version bump.
20 Jan 2013; Mike Gilbert <floppym@gentoo.org> PyGithub-1.10.0.ebuild:
Add PYTHON_USEDEP to setuptools dep.
diff --git a/dev-python/PyGithub/PyGithub-1.11.1.ebuild b/dev-python/PyGithub/PyGithub-1.11.1.ebuild
new file mode 100644
index 000000000000..ae5ac7db877c
--- /dev/null
+++ b/dev-python/PyGithub/PyGithub-1.11.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyGithub/PyGithub-1.11.1.ebuild,v 1.1 2013/02/10 05:31:47 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} )
+# TODO(floppym): Investigate test failures with python-3.3
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to access the Github API v3"
+HOMEPAGE="http://vincent-jacques.net/PyGithub"
+# Use github since pypi is missing test data
+SRC_URI="https://github.com/jacquev6/PyGithub/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}