summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-29 16:13:54 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-29 16:13:54 +0000
commit65df43c19dce8c32f0a12c96ef8a6527e6f0c75b (patch)
treec56eb70361e722377ea0c93c5c946b52b7a0c8f5 /dev-python
parentDelete older ebuild. (diff)
downloadgentoo-2-65df43c19dce8c32f0a12c96ef8a6527e6f0c75b.tar.gz
gentoo-2-65df43c19dce8c32f0a12c96ef8a6527e6f0c75b.tar.bz2
gentoo-2-65df43c19dce8c32f0a12c96ef8a6527e6f0c75b.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyenchant/ChangeLog8
-rw-r--r--dev-python/pyenchant/pyenchant-1.6.2.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/pyenchant/ChangeLog b/dev-python/pyenchant/ChangeLog
index e5c7eb1f468d..9c4868e06b0a 100644
--- a/dev-python/pyenchant/ChangeLog
+++ b/dev-python/pyenchant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyenchant
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/ChangeLog,v 1.21 2010/05/09 18:06:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/ChangeLog,v 1.22 2010/05/29 16:13:54 arfrever Exp $
+
+*pyenchant-1.6.2 (29 May 2010)
+
+ 29 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pyenchant-1.6.0.ebuild, +pyenchant-1.6.2.ebuild:
+ Version bump.
09 May 2010; Raúl Porcel <armin76@gentoo.org> pyenchant-1.6.1.ebuild:
sparc stable wrt #313771
diff --git a/dev-python/pyenchant/pyenchant-1.6.2.ebuild b/dev-python/pyenchant/pyenchant-1.6.2.ebuild
new file mode 100644
index 000000000000..4f5c44768582
--- /dev/null
+++ b/dev-python/pyenchant/pyenchant-1.6.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/pyenchant-1.6.2.ebuild,v 1.1 2010/05/29 16:13:54 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for the Enchant spellchecking wrapper library"
+HOMEPAGE="http://pyenchant.sourceforge.net http://pypi.python.org/pypi/pyenchant"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-text/enchant-1.4.0
+ dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+DOCS="README.txt TODO.txt"
+PYTHON_MODNAME="enchant"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # TestInstallEnv tests are broken with Python 3 (enchant.tokenize is wrongly imported as tokenize).
+ sed -e "s/test_basic/_&/;s/test_UnicodeInstallPath/_&/" -i enchant/tests.py || die "sed failed"
+}